Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Showing results for 
Search instead for 
Did you mean: 

error starting the database

Go to solution
Dan Copeland
Regular Advisor

error starting the database

Hi all,

When our DBA's tried to start a database it is coming up with the following errors

Oracle8 Enterprise Edition Release - Production
With the Partitioning and Objects options
PL/SQL Release - Production
ORACLE_HOME = /ad_ale_pr/orabin/
System name: HP-UX
Node name:
Release: B.11.00
Version: U
Machine: 9000/800
Instance name: pXXX
Redo thread mounted by this instance: 0
Oracle process number: 0
Unix process pid: 5157, image: oraclepXXX

File '/dev/async' not present : errno=2

Has anybody seen this before is this a database or a HPUX error. Please advise.

Jeff Schussele
Honored Contributor

Re: error starting the database

Hi Frank,

Looks like an OS error to me.
Specifically the device file /dev/async is missing.
Try running
insf -e
to reinstall any missing special files.
If that doesn't recreate it, then try to restore from backup. If not on tape then you'll have to recreate it which implies you'll need to know the major & minor numbers for the device.

PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
S.K. Chan
Honored Contributor

Re: error starting the database

If you're not suppose to use "async" but got it "turn-on" in init.ora file ..
then this error will come up upon startup. Change it to FALSE.
If you're using "async" then /dev/async is probably missing. Recreate it ..
# /sbin/mknod /dev/async c 101 0x0
# chown oracle:dba /dev/async
# chmod 660 /dev/async