cancel
Showing results for 
Search instead for 
Did you mean: 

expect on hp-ux 11.31

SOLVED
Go to solution
long_live_unikum
Occasional Contributor

expect on hp-ux 11.31

Hi!

I have downloaded expect from the following site:
http://hpux.connect.org.uk/hppd/hpux/Tcl/expect-5.43/
and installed it.
Unfortunately I get the error message
"/usr/lib/hpux32/dld.so: Unable to find library 'libtcl.so'.
Killed"
as soon as I start expect. I'm running HP-UX 11.31.
Any hints?
6 REPLIES
James R. Ferguson
Acclaimed Contributor

Re: expect on hp-ux 11.31

Hi:

I presume that you installed all of the runtime dependencies. That said, this thread may help you:

http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1134253

Regards!

...JRF...

Steven E. Protter
Exalted Contributor
Solution

Re: expect on hp-ux 11.31

Shalom,

I would presume that either the dld.so library is not present, not on the SHLIB_PATH.

The obvious answer is that required dependencies are not installed. The website clearly lists them.

swlist -l product | grep make
swlist -l product | grep tcltk

Read this perhaps for further clues:

http://hpux.connect.org.uk/hppd/cgi-bin/wwwtar?/hpux/Tcl/expect-5.43/expect-5.43-src-11.11.tar.gz+expect-5.43/HPUX.Install+text

http://hpux.connect.org.uk/hppd/hpux/Tcl/expect-5.43/readme.html

http://hpux.connect.org.uk/hppd/hpux/Tcl/expect-5.43/man.html

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Nischal Tiwari
Occasional Advisor

Re: expect on hp-ux 11.31

1: Check your Path
$env | grep LD_LIBRARY

2: Check your binaries are installed correctly and of proper version(expect in the site is only supported on Tcl 8.2 and up ).
swlist should help as suggested above.
"ALPHA AND BETA RELEASES OF TCL/TK ARE NOT SUPPORTED"

3: If nothing works uninstall expect/tcl and reinstall it.
tcl link
http://hpux.connect.org.uk/hppd/hpux/Tcl/tcltk-8.5.8/

Wild guess is your tcltk is not installed properly as it has following dependencies

expat fontconfig freetype gettext libXft libXrender libiconv zlib
Dennis Handly
Acclaimed Contributor

Re: expect on hp-ux 11.31

>SEP: I would presume that either the dld.so library is not present

The system won't run for long if dld.so isn't present. And it is dld.so that's printing the message that "libtcl.so" is missing.
long_live_unikum
Occasional Contributor

Re: expect on hp-ux 11.31

Thanks. tcltk was not installed. What needs to be done is install tcltk first, then expect.
Nischal Tiwari
Occasional Advisor

Re: expect on hp-ux 11.31

Before you end the thread.Please assign points!