Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

export DISPLAY from hp-ux to linux(Debian) doesn't work

SOLVED
Go to solution
Domenico_1
Occasional Advisor

export DISPLAY from hp-ux to linux(Debian) doesn't work

On the linux WS :
I executed xhost +
The following process is running:
/usr/bin/X11/X :0 -deferglyphs 16 -nolisten tcp vt7 -auth /var/lib/gdm/:0.Xauth
I suspect a security setting not done.
Who can help?
6 REPLIES
Dirk Wiedemann
Respected Contributor
Solution

Re: export DISPLAY from hp-ux to linux(Debian) doesn't work

Hello,

I think with "xhost +" you grant access to your local X-server to everybody. That's always a security risc.
Their is a much better way if you want to redirect the output of X-application on HP-UX to your local linuxbox:
- install ssh on your HP-UX system
- on your linux system set Forward X11 to yes in /etc/ssh/ssh_config
- on your hp system edit the config file /usr/local/etc/openssh/sshd_config as follow:
ForwardX11 yes
X11DisplayOffset 10
X11UseLocalHost no
XAuthLocation /usr/bin/X11/xauth
- log in via ssh
The DISPLAY variable is correctly setting by ssh, you don't need the xhost command.
And your whole communication is encrypted!

You can get openssh for HP-UX here:
http://hpux.connect.org.uk/hppd/hpux/Networking/Admin/openssh-3.4p1/

Dirk
Eric Ladner
Trusted Contributor

Re: export DISPLAY from hp-ux to linux(Debian) doesn't work

Another thing to be aware of. HP requires some uncommon X extensions that cause some of the programs exported from the HP machine to a Linux box not to work. I ran into this problem frequently with Omniback 3.5.
Dirk Wiedemann
Respected Contributor

Re: export DISPLAY from hp-ux to linux(Debian) doesn't work

Hello Eric,

OB 3.5 works very fine in my environment, never any problems.
But OB 4.1 is dreadful. You can run it with setting the linux Xserver to DefaultDepth 8 in Section "Screen" of XF86Config.
Perhabs this is a solution to your problems with OB 3.5 too.

Dirk
Stuart Browne
Honored Contributor

Re: export DISPLAY from hp-ux to linux(Debian) doesn't work

Domenico, what errors do you actually get when you launch your X client from the HP-UX machine?
One long-haired git at your service...
Heiner E. Lennackers
Respected Contributor

Re: export DISPLAY from hp-ux to linux(Debian) doesn't work

Hi,

Debian's default settings are high security settings. The default for the X Server is not to accept any network connection to X at all. Take a look at
/usr/X11R6/lib/X11/xinit/xserverrc

#!/bin/sh
exec /usr/bin/X11/X -dpi 100 -nolisten tcp

Remove the "-nolisten tcp" and restart your X and it should go (at least if you start your X with startx. i haven't testet it with xdm/gdm/kdm by now. if it does not go you should take a look at the xdm/gdm/kdm configurations).

Heiner
if this makes any sense to you, you have a BIG problem
Domenico_1
Occasional Advisor

Re: export DISPLAY from hp-ux to linux(Debian) doesn't work

The error is the following:
he DISPLAY environment variable is set to "mylinuxWS.brussels.hp.com:0.
0", but
the current configuration won't allow ignite to run on that display.

The DISPLAY environment variable may be incorrect, or, if you are
running ignite remotely, you may need to allow the remote system
to access your local X server by typing

/usr/bin/X11/xhost +gemini

on your local machine.

Do you want to proceed using the terminal version of ignite?
(yes or no) [yes]

Today I tested the solution proposed by Dirk, with SSH and this is great.

Heiner I will try yours and let you know.

Many thank to everybody helping me entering in this new world.