General
cancel
Showing results for 
Search instead for 
Did you mean: 

f70 flat panel display w/ Red Hat 8.0

Susan A
Occasional Visitor

f70 flat panel display w/ Red Hat 8.0

My Pavilion 783 is set up to dual boot RH 8.0 & XP. When I installed RH, it probed the monitor and came up with "hp f70" and a range of refresh rates (as well as Intel 845 for the video card, which is correct). I set the display to 1280 x 1024 (the native resolution). When Gnome started, the display showed a wide black bar along the top and bottom, only using about 80% or so of the height (but the full width). Everything on the screen was stretched out. I got a popup message on my screen (from the monitor itself, not from Linux) to "Set PC at 1280 x 1024 60 Hz refresh rate" - it was already set at 1280 x 1024, but the refresh rate was a range from 31-80 Hz or thereabouts. Also, when I clicked on the menu button on the monitor, it said "Out of range" at the top.

So I changed the refresh rate to 60, and rebooted - and X-Server would not start (it said "screen not found" somewhere in there). Being new to Linux, not familiar with the command line, and since it was a fresh install anyway, I reinstalled RH. When the option came up, I tried a 1280 x 1024 generic laptop display. Then tried keeping it at f70 but setting the refresh rate to 60 during the install. Then tried choosing the 1720 flat panel. In all of these, X-server always failed to start once I rebooted and I ended up reinstalling RH. Did not see a generic 17" flat panel display listed. Is my monitor incompatible? Or is the integrated video card the problem? When I had this CPU built to order, I chose integrated video with the intention of upgrading it later to one that supported dual displays, DVI interface, etc. - but I can't afford to upgrade it now!
5 REPLIES
Kodjo Agbenu
Honored Contributor

Re: f70 flat panel display w/ Red Hat 8.0

Hi,

If I were you, I would try to edit /etc/X11/XF86Config by hand. If you need help doing so, please post your current config.

Make sure that "HorizSync" and "VertRefresh" reflect the datasheet of your flat LCD display :

http://h20015.www2.hp.com/content/common/manuals/bph07459/bph07459.pdf

First, try HorizSync = "30-80" and VertRefresh = "56-75".

If it doesn't work, try VertRefresh="60" and leave HorizSync unchanged.

Good luck.

Kodjo
Learn and explain...
Susan A
Occasional Visitor

Re: f70 flat panel display w/ Red Hat 8.0

Thank you for your response... unfortunately, that did not work. It was already set at 30-80 & 56-75 @ 1280 x 1024, but still condensing it to what looks like 1280 x 960. So I tried changing the vertical to 60 as per your suggestion, that did not help either. Then I deleted the 1280 x 960 mode option from the config file entirely, that did not help either. Any other ideas? All of the settings appear to be correct, the display settings radio button is at 1280 x 1024, it just refuses to stop displaying at what looks like 1280 x 960 and my monitor tells me it's out of range, "Set PC at 1280 x 1024 @ 60 Hz" - which is exactly what it IS set at - any more ideas? I am attaching the config file.
Susan A
Occasional Visitor

Re: f70 flat panel display w/ Red Hat 8.0

One other thing I forgot to mention - already tried CTRL ALT + and CTRL ALT - which did not help either.

Also tried deleting all resolutions except 1280 x 1024, but then X server wouldn't start.
Peter D. Vouvounas
Occasional Visitor

Re: f70 flat panel display w/ Red Hat 8.0

I have the same issue that Susan A mentioned - trying to setup an HP f70 monitor with RedHat 8 and I see the exact issues any help

TIA

Best Regards

PeterV wb3fsr@comcast.net
Susan A
Occasional Visitor

Re: f70 flat panel display w/ Red Hat 8.0

Peter,
I never did get it to work, unfortunately, and gave up. But I did a search just now on the Intel site and came up with this driver (don't remember seeing it there the last time I looked):

http://downloadfinder.intel.com/scripts-df/filter_results.asp?strOSs=39&strTypes=DRV%2CARC&ProductID=865&OSFullName=Linux*&submit=Go%21

I'd try it myself first, but I have had enough frustration with this issue already!