General
cancel
Showing results for 
Search instead for 
Did you mean: 

hp lh3000 megaraid driver not working on suse 9.0

Gael Lams
Occasional Contributor

hp lh3000 megaraid driver not working on suse 9.0

Hi guy

I'm trying to install suse professional 9.0 on an HP LH 3000 which has an integrated Netserver raid (megaraid)
The installation of SuSe 7 works like a charme but SuSe9 is unable to detect the hard disk.

Is it possible that the megaraid driver for HP Netraid exists but is not included with the default distribution? Is there a place where I could find an updated driver?
I also tried with linuxrc loading by hand the 2 available kernel module but the program keeps saying "trying to load module" and nothing happen

Thanx

GaÃ
4 REPLIES
Steven E. Protter
Exalted Contributor

Re: hp lh3000 megaraid driver not working on suse 9.0

Ive heard of two scenarios:

1) The Suse7 install does something to the disks that make it hard or impossible for Suse9 to detect. A suggestion I have seen is to not use grub, try lilo. I can't say whether that will work.

2) The drivers from HP don't support Suse9. HP is limited in the distributions it supports. That doesn't mean it won't work with others, but there is no guarantee.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Jeroen Peereboom
Honored Contributor

Re: hp lh3000 megaraid driver not working on suse 9.0

L.S.

other threads on the subject 'hard disk not detected at install time' suggest to create a driver diskette for the megaraid controller.

JP.
Grant_23
Occasional Visitor

Re: hp lh3000 megaraid driver not working on suse 9.0

I had a similar problem with my HP LPr and LT 6000r servers with the NetRAID controller. SuSE 9 has two drivers for the MegaRAID: MegaRAID and MegaRAID-old. With the newer MegaRAID driver SLES9 would probe but not find and hard drives. But, if during install you select to do a "manual install" and manually select the MegaRAID-old module, SuSE will recognize the hard drives and complete the installation. However, after a reboot linux will be unable to see the root partition giving an error: "Waiting for device /dev/sda2 to appear: ..... not found * device nodes"... "no root device found; exiting to /bin/sh" because the install failed to modify the /etc/sysconfig/kernel file with a reference to "megaraid-old" (it will still be referencing "megaraid"). To fix this you need to go through the manual install process again and load the megaraid-old driver, but instead of starting the installation over, you can choose to boot from the hard drive which will allow SuSE to finish the initial installation and give you the ability afterwards to manually edit the kernel file adding "-old" to the end of "megaraid" in the INITRD_MODULES section. Don't forget to run "mkinitrd" to complete the modification to the /etc/sysconfig/kernel file.
Poetic Intensity
Occasional Visitor

Re: hp lh3000 megaraid driver not working on suse 9.0

I tried to follow the instructions of using the old megaraid module for SLES9 and it worked *perfectly*. I made the required changes to the /etc/sysconfig/kernel file, ran mkinitrd, and it successfully booted.d

Thank you so much for sharing. Take care.