General
cancel
Showing results for 
Search instead for 
Did you mean: 

hp-ux 11.11i and postgreSQL 7.2 --> configure error

thierry masson
Occasional Visitor

hp-ux 11.11i and postgreSQL 7.2 --> configure error

Hi,

I'm trying to compile the latest postgreSQL version (7.2) to get it running under hp-ux 11.11i.
I'm unsuccessfull so far, since "configure" does not end properly, but fails when "checking types of arguments for accept()...".
I guess this has something to deal with "sys/socket.h" but i can't figure out how to solve the problem.
I'm using gcc 3.0.1 and gmake 3.79.1. (no lex, no yacc).
6 REPLIES
harry d brown jr
Honored Contributor

Re: hp-ux 11.11i and postgreSQL 7.2 --> configure error

You made most of the correct steps, except loading the "as" from gnu:

http://hpux.connect.org.uk/hppd/hpux/Gnu/binutils-2.11.2/

which I found in this thread, thanks to Stefan!

http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0x6fc8cf38d6bdd5118ff10090279cd0f9,00.html


live free or die
harry
Live Free or Die
thierry masson
Occasional Visitor

Re: hp-ux 11.11i and postgreSQL 7.2 --> configure error

Thanks for your reply !

But I've already installed the binutils 2.11.2 package, along with gcc.

Sorry if I forgot to mention it ... but I thought this was obvious (how could gcc work fine w/o binutils ????)

Another idea ?

harry d brown jr
Honored Contributor

Re: hp-ux 11.11i and postgreSQL 7.2 --> configure error

Thierry,

I know this is old, but some things might still hold true:

http://www.cise.ufl.edu/depot/doc/postgres/FAQ_HPUX


And yes, gcc does not always need gnu's "as" to work, but with HP I've found that it's been very necessary.

live free or die
harry
Live Free or Die
harry d brown jr
Honored Contributor

Re: hp-ux 11.11i and postgreSQL 7.2 --> configure error

Thierry,

Here's an explaination, followed (if you click on next thread) by many followups:

http://archives.postgresql.org/pgsql-hackers/2001-11/msg01237.php


live free or die
harry
Live Free or Die
Umang Patel
Occasional Visitor

Re: hp-ux 11.11i and postgreSQL 7.2 --> configure error

I am currently having the excat same problem with trying to install postgresql 7.2 with my 11.11i system. Do the march patch bundles fix this preblem, or is there a workaround for this issue ?

I have gcc, binutils, flex, and bison installed.

The problem seems to be HP-UX. I was able to install it successfully on a RedHat liunx system

Thanks
Herve CADROY
Occasional Visitor

Re: hp-ux 11.11i and postgreSQL 7.2 --> configure error

for compiling postgres 7.2 or 7.2.1 on HPUX11.11
run ./configure
=> checking types of arguments for accept()... configure: error: could not determine argument types
open configure file : vi configure
find this line :
cat >> confdefs.h < #define PG_VERSION "$VERSION"
EOF
and repalce by
cat >> confdefs.h < #define _XOPEN_SOURCE_EXTENDED
#define PG_VERSION "$VERSION"
EOF

and run agin ./configure
now open src/Makefile.global
find the line begin by CFLAGS=
and add in this line :
-D_XOPEN_SOURCE_EXTENDED

After this step you need to modify 3 files
->src/backend/libpq/pqformat.c
->src/interfaces/libpq/fe-misc.c
->src/interfaces/odbc/socket.c
for adding :
#include
#include

and Run gmake...


Herv?? CADROY