General
cancel
Showing results for 
Search instead for 
Did you mean: 

hpasm does not start on DL380 G5 with Debian 4.0 Etch

Ingo Rogalsky
Occasional Visitor

hpasm does not start on DL380 G5 with Debian 4.0 Etch

Hello,

when starting hpasm on a Proliant DL380 G5 server with Debian 4.0 Etch the program IrqRouteTbl crashes with a segmentation fault and hpasm does not start correctly. This happens with the installed packages

hp-OpenIPMI-7.8.0-108.etch26.i386.deb
hpasm-7.8.0-100.etch26.i386.deb

The kernel version is 2.6.18-6-686-bigmem. I tried some other of the standard Debian kernels without success.

Does anybody know a solution or workaround for this problem?

Ingo

------------------------------------------------------
# /etc/init.d/hpasm start

Using high performance hp-OpenIPMI device driver
/opt/compaq/hpasmd/etc/hpasmd: line 179: 11114 Segmentation fault /opt/compaq/hpasmd/bin/IrqRouteTbl
Starting hp-OpenIPMI:
Starting Proliant High Performance IPMI based System Health Monitor (hpasmxld): [ SUCCESS ]

Starting Foundation Agents (cmafdtn): cmathreshd cmahostd cmapeerd
Starting Threshold agent (cmathreshd): [ SUCCESS ]

Starting Host agent (cmahostd): [ SUCCESS ]

Starting SNMP Peer (cmapeerd): [ SUCCESS ]


Starting Server Agents (cmasvr): cmastdeqd cmahealthd cmaperfd
Starting Standard Equipment agent (cmastdeqd): [ SUCCESS ]

Starting Health agent (cmahealthd): [ SUCCESS ]

Starting Performance agent (cmaperfd): [ SUCCESS ]


Starting Storage Agents (cmastor): cmaeventd cmaidad cmafcad cmaided cmascsid cmasasd
Starting Storage Event Logger (cmaeventd): [ SUCCESS ]

Starting IDA agent (cmaidad): [ SUCCESS ]

Starting FCA agent (cmafcad): [ SUCCESS ]

Starting IDE agent (cmaided): [ SUCCESS ]

Starting SCSI agent (cmascsid): [ SUCCESS ]

Starting SAS agent (cmasasd): [ SUCCESS ]


hpasm: Server Management is enabled

Using high performance hp-OpenIPMI device driver


hp-OpenIPMI Status:
Module Size Used by
ipmi_si 37632 0
ipmi_devintf 9320 0
ipmi_msghandler 33728 2 ipmi_si,ipmi_devintf

hpasmxld is stopped... [ SUCCESS ]

Status of Foundation Agents (cmafdtn): cmathreshd cmahostd cmapeerd

cmathreshd is running... [ SUCCESS ]


cmahostd is running... [ SUCCESS ]


cmapeerd is running... [ SUCCESS ]

Status of Server Agents (cmasvr): cmastdeqd cmahealthd cmaperfd

cmastdeqd is running... [ SUCCESS ]


cmahealthd is running... [ SUCCESS ]


cmaperfd is running... [ SUCCESS ]

Status of Storage Agents (cmastor): cmaeventd cmaidad cmafcad cmaided cmascsid cmasasd

cmaeventd is stopped... [ SUCCESS ]


cmaidad is stopped... [ SUCCESS ]


cmafcad is stopped... [ SUCCESS ]


cmaided is running... [ SUCCESS ]


cmascsid is running... [ SUCCESS ]


cmasasd is running... [ SUCCESS ]

3 REPLIES
Colin Topliss
Esteemed Contributor

Re: hpasm does not start on DL380 G5 with Debian 4.0 Etch

Hi,

I'm seeing the same thing on SLES10 on a couple of bl460cG1 blades (3 out of about 100 - all the others are OK). Problem first appeared with PSP 7.9.0, and persists on PSP 7.9.1, on both SLES10 and SLES10 SP1.

I'm checking something out with HP later today - I'll post the results up later.
Ingo Rogalsky
Occasional Visitor

Re: hpasm does not start on DL380 G5 with Debian 4.0 Etch

Hello,

I didn't realized, that my posting got through. The forum web server has been really slow on Friday and I didn't got a reply from the web server after submitting my question.

Anyway. In the meantime I found a solution. After installing a new Firmware (2008.01.24), hpasm works.

Ingo Rogalsky
Colin Topliss
Esteemed Contributor

Re: hpasm does not start on DL380 G5 with Debian 4.0 Etch

For anyone else reading this thread, my problem appears to be because I have 2 x dual-core CPUs, and the steps were not the same.

Swapping a CPU over with one that had the same step fixed the issue.

We're still looking into this a bit further.

Colin.