General
cancel
Showing results for 
Search instead for 
Did you mean: 

installing problem (from very beginner)

sam kim_1
Frequent Advisor

installing problem (from very beginner)

1) i just have a book and cdrom of linux
2) i tried to install linux on my blank hard drive last night
3) during the process, everything was good until i have an error right after i typed at the prompt 'startx'
4) obviously, i had no chances at all to see/go linux colorful screen
5) the error (after i typed '#startx') was
6) execve failed for /usr/X11R6/bin/X
(errno 2) - X11TransSocketUNIXConnect: Can't connect: errno=2 .....
xinit: No such file or directory (error2): unable to connect to X server
xinit: No such process (error3): server error
------------------------------
i have a 'S3Trio64-DX' video card and i thought i select this one during the install/configure !

i tried to reinstall 3 times and tried to fix this problem, but failed !!

i think i need something very step-by-step with an example to install/configure in order to use linux !!!

help me out, pls


2 REPLIES
Albert E. Whale, CISSP
Honored Contributor

Re: installing problem (from very beginner)

Sam,

Welcome to the wwonderful World of Linux.

We have all had our share of these very same problems.

First of all, what version of Linux are you attempting to install. My favorites (for ease of use and Installation) are RedHat and Linux Mandrake. Linux Mandrake uses a kernel (and applications) compiled for the Pentium series and above. But enough of that for now.

Have you checked your disk space? What does the df command return? Sometimes a Full filesystem will not allow software to be installed (because it's full!).

My first recommendation is to remove the XFree*.rpms and re-install the libraries. There have been times that these do not all get installed properly.

Then reboot and re-install the OS, make sure that you are running the X Configurator which comes with the OS.

Let me know how we're doing so far, and I answer back again, and gladly accept the points as well!
Sr. Systems Consultant @ ABS Computer Technology, Inc. http://www.abs-comptech.com/aewhale.html & http://www.ancegroup.com
Rumen Ginev
Frequent Advisor

Re: installing problem (from very beginner)

Sam,

Assuming you have properly installed XFree86*.rpms check if you use standard (SVGA) or accelerated server:

cd /etc/X11
ls -l

You have to see something like:
X -> ../../usr/X11R6/bin/XF86_SVGA

If X is link to some different than XF86_SVGA, install "XFree86-SVGA*.rpm" and point X to XF86_SVGA:

ln -s /path/to/XF86_SVGA /etc/X11/X

Run Xconfigurator, choose you monitor as Super VGA 800/600; resolution 16 bit or less (DO NOT try with 32 bit color).
Enter startx.
If X is still failing refer to:
http://www.linuxdoc.org/LDP/gs/gs.html
In this great book you will find step-by-step instructions to configure X by hand.

For beginners in Linux I reccomend to start with Mandrake 7.*

Regards,
Rumen