Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

jakarta-tomcat-4.1.24 from oracle 817 to 9205

paolo barila
Valued Contributor

jakarta-tomcat-4.1.24 from oracle 817 to 9205

On our hpux boxes I use to connect a jakarta-tomcat-4.1.24 to a oracle 817 server via jdbc.
So I have a repository_database.xml with
...
jcd-alias="default"
default-connection="true"
platform="Oracle"
jdbc-level="2.0"
driver="oracle.jdbc.driver.OracleDriver"
protocol="jdbc"
subprotocol="oracle"
dbalias="thin:@eytdb02:1521:xx"
username="yy"
password="zz"
batch-mode="false"
useAutoCommit="1"
ignoreAutoCommitExceptions="false"
>

...

Now Oracle server 817 has to migrate to 9205,
what should I change on jakarta-tomcat side?
10x
share share share
5 REPLIES
TwoProc
Honored Contributor

Re: jakarta-tomcat-4.1.24 from oracle 817 to 9205

Actually,

I think you'll be surprisingly happy to find that you won't need to change a thing.

If you were on a pre 8.1.x version (like 8.0) you might have a problem (and then again maybe not with jdbc), but what you've got already for a client connection should be fine.

I've use that same jdbc level code on both 8.1.x and 9.x databases before.

Of course, test before go-live!
We are the people our parents warned us about --Jimmy Buffett
Steven E. Protter
Exalted Contributor

Re: jakarta-tomcat-4.1.24 from oracle 817 to 9205

Shalom,

The oracle support matrix, available on http://metalink.oracle.com and perhaps http://technet.oracle.com says version 9 supports java 1.4.

10g requires 1.4 or above if I'm not mistaken, so you are good for a while.

Testing is a must.

The migration procedure for your data is complex and requires you be very precise in following all instructions.

Patching your system in advance of the install is key as well.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
paolo barila
Valued Contributor

Re: jakarta-tomcat-4.1.24 from oracle 817 to 9205

thanks,
I'll follow your suggestions,
can you help me as well about an error I got about this in:

.../webapps/integration/WEB-INF/log/awaLog.log

Caused by: org.apache.torque.TorqueException: java.sql.SQLException: ORA-00600: internal error code, arguments: [ttcgcshnd-1],
[0], [], [], [], [], [], []
share share share
paolo barila
Valued Contributor

Re: jakarta-tomcat-4.1.24 from oracle 817 to 9205

Hi,
I copied
$ORACLE_HOME/jdbc/classes12.jar
to
$TOMCAT_HOME/webapps//WEB-INF/lib/classes12.jar

and it works,

Pablo
share share share
paolo barila
Valued Contributor

Re: jakarta-tomcat-4.1.24 from oracle 817 to 9205

see above
share share share