cancel
Showing results for 
Search instead for 
Did you mean: 

kernel painic again

blueblue
Occasional Visitor

kernel painic again

hi , anyone , i met a problem when i want to update the kernel from 2.4.20-9 to 2.4.22, i did as follow
make mrproper
make xconfig
make bzImage
make modules
make modules_install
and then copy some files to /boot such as .config and arch/i386/boot/bzImage and Systerm.map .finally , use mkinitrd to generate the .img file , configure the grub.conf file .
title Red Hat Linux (2.4.22)
root (hd0,0)
kernel /vmlinuz-2.4.22 ro root=LABEL=/ hdc=ide-scsi
initrd /initrd-2.4.20-22.img
, at last reboot
but there is stange error
Mounting /proc
Mounting root filesystem
kjournald starting. Commit interval 5 seconds
EXT3-fs: mounted filesystem with ordered data mode.
pivotroot: pivot_root(/sysroot,/sysroot/initrd) failed: 2
umount /initrd/proc failed: 2
Freeing unused kernel memory: 212K freed
Kernel panic: No init found. Try passing init= option to kernel
---

i don't know how to fix , is there someone meet the same problem before , and anyone can tell me how i can fix it .
3 REPLIES
Alexander Chuzhoy
Honored Contributor

Re: kernel painic again

what about make dep before make bzImage?
Alexander Chuzhoy
Honored Contributor

Re: kernel painic again

why your initrd has different version?
if your newer kernel is 2.4.22
then the command to build the newer initrd would be the following:

mkinitrd /boot/initrd-2.4.22.img 2.4.22
Caesar_3
Esteemed Contributor

Re: kernel painic again

Hello!

Try to change :
kernel /vmlinuz-2.4.22 ro root=LABEL=/ hdc=ide-scsi

to:
kernel /vmlinuz-2.4.22 ro root=/dev/hda1 hdc=ide-scsi

!the /dev/hda1 should be the partition device
where is the kernel is.

Caesar