Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

kernel: set_rtc_mmss: can't update from 59 to 0

SOLVED
Go to solution
Robert-Jan Goossens
Honored Contributor

kernel: set_rtc_mmss: can't update from 59 to 0

Dear admins,

I've got three systems reporting above error messages on a irregular bases. All three are on the same patch level. All systems have xntp configured and get the time from lan time gps servers (2X)

# uname -a
Linux lx00x7 2.4.21-47.EL #1 Wed Jul 5 20:46:55 EDT 2006 i686 i686 i386 GNU/Linux

Aug 5 14:00:00 lx00x8 kernel: set_rtc_mmss: can't update from 59 to 0
Aug 3 06:00:00 lx00x2 kernel: set_rtc_mmss: can't update from 59 to 0
Aug 1 11:00:00 lx00x7 kernel: set_rtc_mmss: can't update from 59 to 0

Any idear what could be the cause of these errors?

Thanks in advanced
Robert-Jan
7 REPLIES
Steven E. Protter
Exalted Contributor
Solution

Re: kernel: set_rtc_mmss: can't update from 59 to 0

Shalom,

This is probably caused by a variance between the hardware clock and the click kept by the OS.

Bet these systems have been running for a very long time.

Use hwclock command to put the hardware clock at the same time as the OS or software clock from xntpd.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Stuart Browne
Honored Contributor

Re: kernel: set_rtc_mmss: can't update from 59 to 0

Wow, horrible mix-up between the kernel and NTP.

The long story is.. kernel 'tweak' gone haywire with regards to.. err.. stuff I have no idea what it means to tell the truth.. ;)

http://www.mailinglistarchive.com/fedora-list@redhat.com/msg47237.html

This seems promising though.
One long-haired git at your service...
Steven E. Protter
Exalted Contributor

Re: kernel: set_rtc_mmss: can't update from 59 to 0

Shalom,

I might add that running up2date on the system or simply upgrading to a newer kernel might also help with the message.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Robert-Jan Goossens
Honored Contributor

Re: kernel: set_rtc_mmss: can't update from 59 to 0

Hi Steven/Stuart,

uptimes
lx00x8 up 52 days
lx00x2 up 63 days
lx00x7 up 62 days

# hwclock -r
is reporting an average diff of -0.658771 seconds

I will try to set the HWClock tonight, and have some extra logging enabled.

Thanks,
Robert-Jan

Ps.
We have a project running to update the systems to the latest Redhat version(60+ systems) but that will take a few months.

Stuart, thanks for the link :-)
Stuart Browne
Honored Contributor

Re: kernel: set_rtc_mmss: can't update from 59 to 0

I'd love to recipricate with some lovely uptimes, but we just moved all our servers to a new structure, thus the phased migration over the previous week or so means they've all just rebooted.. Most were up a year.

We have another small cluster that's been up since Jan though.. Not under load, so not real..
One long-haired git at your service...
Robert-Jan Goossens
Honored Contributor

Re: kernel: set_rtc_mmss: can't update from 59 to 0

Used the systohc option to sync the system time to the hardware clock.

--systohc
Set the Hardware Clock to the current System Time.

I think the time difference is now close enough.

# hwclock -r;date
Tue Aug 28 10:01:17 2007 -0.093787 seconds
Tue Aug 28 10:01:17 CEST 2007

I will keep a close eye on these systems for a few weeks.

Thanks for your support guys!
Robert-Jan

Stuart same here, we installed Update 8 a few months ago, some of these Linux servers run months (a year) without a reboot. But I have to add these systems are application servers specially installed for one or two apps.
Steven E. Protter
Exalted Contributor

Re: kernel: set_rtc_mmss: can't update from 59 to 0

If I was right, the messages should stop.

Update 9 is released and we've tested the non rhcs portion of it and find it to be reasonable, though not problem free.

Regards,

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com