Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

libcrypto.so.2 & libssl.so.2 library file required....

Dayanand Naik
Frequent Advisor

libcrypto.so.2 & libssl.so.2 library file required....

Hi Folks,

I'm installing Nessus system scanner on Red Hat 7.1 Linux, but while doing so i get errors saying dependencies failed as for the following two files are not found.

libcrypto.so.2
libssl.so.2

Can you all tell me where can i find these files and install it. After searching thruout the net, i did not find one. Some did mention of installing OpenSSL rpms which i did but no result.

Suggestion Welcomed.

Cheers & Regards,
Dayanand Naik.
Dayanand Naik
4 REPLIES
Marcin Golembski_1
Honored Contributor

Re: libcrypto.so.2 & libssl.so.2 library file required....

Dayanand Naik
Frequent Advisor

Re: libcrypto.so.2 & libssl.so.2 library file required....

Hi Marcin,

I have installed OpenSSL the same product the link what you have specified but still it does not install the libcrypto.so.2 file.

I searched the entire disk and found libcrypto.so and libcrypto.so.1

Any other site....

Cheers & Regards
Dayanand Naik.
Dayanand Naik
Marcin Golembski_1
Honored Contributor

Re: libcrypto.so.2 & libssl.so.2 library file required....

You must have installed an older version of OpenSSL... I've just downloaded openssl-0.9.6b-2.i586.rpm and it contains libcrypto.so.2 and libssl.so.2 in it. libcrypto.so.1 is not even referenced in the package.

Meinhard Benn
Occasional Visitor

Re: libcrypto.so.2 & libssl.so.2 library file required....

hi,

if you have /usr/lib/libssl.so.0.9.6 on your system just create a symbolic link to it (as root):

ln -s /usr/lib/libssl.so.0.9.6 /usr/lib/libssl.so.2

do the same for libcrypto if required:

ln -s /usr/lib/libcrypto.so.0.9.6 /usr/lib/libcrypto.so.2

worked fine for me, nessus runs.

meinhard.