cancel
Showing results for 
Search instead for 
Did you mean: 

libgcc install error

SOLVED
Go to solution
richard hung
Occasional Contributor

libgcc install error

I downloaded a libgcc depot (libgcc-4.2.3-hppa-11.11.depot) and used swinstall to install it. It didn't give me any error at that time but swverify reveals something's wrong with the istallation:

root, xxxxxx, root: swverify libgcc

======= 11/25/08 11:43:39 PST BEGIN swverify SESSION
(non-interactive) (jobid=xxxxxx-0077)

* Session started for user "root@xxxxxx".

* Beginning Selection
* Target connection succeeded for "xxxxxx:/".
* Software selections:
libgcc.libgcc-RUN,l=/usr/local,r=4.2.3,a=HP-UX_B./800
* Selection succeeded.


* Beginning Analysis
* Session selections have been saved in the file
"/root/.sw/sessions/swverify.last".
ERROR: "xxxxxx:/": 2 files had errors during this operation.
* The analysis phase failed for "xxxxxx:/".
* Verification had errors.


NOTE: More information may be found in the agent logfile using the
command "swjob -a log xxxxxx-0077 @ xxxxxx:/".

======= 11/25/08 11:43:52 PST END swverify SESSION (non-interactive)
(jobid=xxxxxx-0077)

root, xxxxxx, root: swjob -a log xxxxxx-0077 @ xxxxxx:/
======= 11/25/08 11:43:43 PST BEGIN verify AGENT SESSION (pid=6798)
(jobid=xxxxxx-0077)

* Agent session started for user "root@xxxxxx".
(pid=6798)

* Beginning Analysis Phase.
* Target: xxxxxx:/
* Target logfile: xxxxxx:/var/adm/sw/swagent.log
* Reading source for file information.
* Configured libgcc.libgcc-RUN,l=/usr/local,r=4.2.3
ERROR: File "/usr/local/lib/libgcj.sl" should have mtime "1203664934"
but the actual mtime is "1203643661".
ERROR: File "/usr/local/lib/libstdc++.sl" should have mtime
"1203664933" but the actual mtime is "1203643651".
ERROR: Fileset "libgcc.libgcc-RUN,l=/usr/local,r=4.2.3" had file
errors.

* Summary of Analysis Phase:
ERROR: Verify failed libgcc.libgcc-RUN,l=/usr/local,r=4.2.3
ERROR: 1 of 1 filesets had Errors.
ERROR: The Analysis Phase had errors. See the above output for
details.


======= 11/25/08 11:43:52 PST END verify AGENT SESSION (pid=6798)
(jobid=xxxxxx-0077)

Appreciate any input to my problem here.

Thanks in advance,
Richard
6 REPLIES
Dennis Handly
Acclaimed Contributor

Re: libgcc install error

>but swverify reveals something is wrong with the installation:

You could just ignore it, since the checksum is valid. It seems some swinstall control script has messed up the modification time?
It seems the file on your system is older than what it wants??

Have you carefully looked at the NOTEs and WARNINGs for the swinstall?
richard hung
Occasional Contributor

Re: libgcc install error

I checked the swagent.log and no ERRORs and WARNINGs were recorded during the libgcc install.

What I was trying to do was to install libgcc and gcc-4.2.3-hppa-11.11.depot to compile samba 3.2.4. The installation of the above seems to be fine, but I had an error trying to run configure with option --with-dnsupdate which leads to the discovery of this libgcc "error", not sure if the configure error was due to libgcc not installed properly.

Does anyone have any experience compiling samba ?
Dennis Handly
Acclaimed Contributor

Re: libgcc install error

>not sure if the configure error was due to libgcc not installed properly.

I doubt it. The contents are correct even if the date is wrong.
richard hung
Occasional Contributor

Re: libgcc install error

Thanks Dennis, if that's an unlikely source of problem, then can someone give me advise on the following error in trying to compile samba.

gcc 4.2.3
samba 3.2.4

Trying to compile samba with the following configure options:
./configure --with-ldap --with-ads --with-krb5=/usr/local/krb5 --with-winbind --with-pam --with-dnsupdate

And got the following error at the end:
checking uuid/uuid.h usability... no
checking uuid/uuid.h presence... no
checking for uuid/uuid.h... no
configure: error: uuid.h is needed to enable DNS Updates support
Matti_Kurkela
Honored Contributor
Solution

Re: libgcc install error

The error message refers to uuid/uuid.h. That is not a part of gcc. I believe it refers to a small library named "libuuid".

In your case, Samba's configure script is looking for /usr/include/uuid/uuid.h and/or /usr/local/include/uuid/uuid.h and failing to find it. The uuid.h file would describe the library's interface to the compiler, so that the compiler can use the library.

The libuuid is an open-source library which is not part of the gcc package nor of HP-UX standard installation. Unfortunately a pre-built package of libuuid for HP-UX does not seem to be available. You will have to find the source code of that library, compile and install it, then you can try compiling Samba again.

If you cannot find that library, you will have to compile Samba without DNS Update support.

MK
MK
richard hung
Occasional Contributor

Re: libgcc install error

Thanks Matti, I'll try the libuuid route you suggested.