cancel
Showing results for 
Search instead for 
Did you mean: 

linux sound on zt1190

Martin Faltesek
Occasional Visitor

linux sound on zt1190

I have SuSE 7.3 professional running on a zt1190, but am unable to get the sound to work. When using xmms, the first 1 second of sound repeats indefinitely. any advice to get this working?
11 REPLIES
Christoph Rothe_3
Frequent Advisor

Re: linux sound on zt1190

Hi,

unfortunately I do not know that kind of soundcard, but probably you should check DMA and IRQ settings ?

Christoph
kankanhu
Occasional Advisor

Re: linux sound on zt1190

Mine is a zt1180. I also have the same problem with my audio card, which is a VIA AC97. I tried both the driver come w/ the linux kernel and also ALSA driver, neither of them work. Really want to fix that problem.
Hauke Busch
Occasional Visitor

Re: linux sound on zt1190

Try using the latest alsa drivers
0.9.0beta 12. Sound will work with xmms and mplayer.
Unfortunately you will have to compile the alsa sources and you will have to modify your modules.conf file. Mine looks like this:
alias char-major-116 snd
alias char-major-14 soundcore
options snd snd_cards_limit=1 snd_major=116
options snd-via686 snd_index=0
alias snd-card-0 snd-via686
alias sound-slot-0 snd-card-0
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

Hope this helps.

Cheers,
Hauke
kankanhu
Occasional Advisor

Re: linux sound on zt1190

Thanks a lot Hauke.
Acutally, I have also tried that version of alsa. However, I did not make any success at that time. I noticed that there is slight difference between your modules.conf and mine. I will give it a try ASAP. Hope it works for my zt1180 too.
Thanks a lot.
kankanhu
Occasional Advisor

Re: linux sound on zt1190

Hi Hauke:
I tried to that version of alsa just now, and also updated my modules.conf to be exactly as yours as of the sound card configuration. However, when I use xmms, it still stucks.

Is there anything that I should note when I compile the kernel and the alsa driver. For the kernel, I only enabled the sound module and the the oss module. For ALSA, all I did is ./configure and make install. Did I miss something?

My laptop is zt1180. I am using redhat 7.2 with 2.4.18 kernel.
Thank you.
Hauke Busch
Occasional Visitor

Re: linux sound on zt1190

HI,

sorry for the long delay. I was gone over the weekend. I know it can be frustrating having no sound working.
With the lastest alsa drivers, sound works with xmms and the oss output plugin. So make sure that you install ALL of the alsa drivers, libs, utils and oss package. Also ensure that you are really loading the new also modules, i.e. unload old modules first and comment out all the kernel sound mods, like via_82xxx and the like in modules.conf.
You can check for the new moduls using the modinfo command.
modinfo snd-via686 gives me
filename: /lib/modules/2.4.18-4GB/kernel/sound/pci/snd-via686.o
description: "VIA VT82C686A"
author: "Jaroslav Kysela "
license: "GPL"
parm: snd_index int array (min = 1, max = 8), description "Index value fo
r VIA 82C686A bridge."
parm: snd_id string array (min = 1, max = 8), description "ID string for
VIA 82C686A bridge."
parm: snd_enable int array (min = 1, max = 8), description "Enable audio
part of VIA 82C686A bridge."
parm: snd_mpu_port long array (min = 1, max = 8), description "MPU-401 po
rt."
parm: snd_ac97_clock long array (min = 1, max = 8), description "AC'97 co
dec clock (default 48000Hz)."

From the first line I know, the kernel is referring to the lastest alsa driver, which are, in my case, installed in /lib/modules/2.4.18-4GB/kernel/sound

Instead of starting alsa using rcalsound, you can also manulaly do a modprobe:
modprobe -k snd-via686

lsmod should give you the following list of loaded modules:
Module Size Used by Not tainted
snd-via686 6496 0 (autoclean) (unused)
snd-pcm 46528 0 (autoclean) [snd-via686]
snd-timer 9856 0 (autoclean) [snd-pcm]
snd-ac97-codec 22176 0 (autoclean) [snd-via686]
snd-mpu401-uart 2544 0 (autoclean) [snd-via686]
snd-rawmidi 11616 0 (autoclean) [snd-mpu401-uart]
snd-seq-device 3920 0 (autoclean) [snd-rawmidi]
snd 23976 0 (autoclean) [snd-via686 snd-pcm snd-timer snd-ac97-codec snd-mpu401-uart snd-rawmidi snd-seq-device]
soundcore 3268 0 (autoclean) [snd]

The sound problem on HP Omnibooks had been discussed prevoously on the Omnibook mailing list.
http://www.swiss.ai.mit.edu/projects/omnibook/
It is probably worth digging the archives there.
If everything fails, alsa, OSS plugin, you might have another version of hte VIA onboard sound. HP as a subvendor seems to have fiddled around with the hardware, so it seems.
My notebook is a European xt1000, which I think is a zt1000 in the states.

I keep my fingers crossed. Hope you get the sound working.

Hauke
kankanhu
Occasional Advisor

Re: linux sound on zt1190

Thanks a lot Hauke.
I finally found one post in news groups which helped me fix the problem. It's really a BIG suprise to me that the reason is I did not have ACPI working. After modifying the source code of acpi according to the list, my sound card right now works fantastic with the native driver of 2.4.18 kernel.
The add-on benefit is I also have some basic acpi support now. (I can not get my apm working on the machine). At least now acpi can let me power off the laptop, shutoff the display. although I can not query the battery status and some events are not handled correctly.
Again, thanks a lot Hauke. And good luck to you too.
Emma_2
Occasional Visitor

Re: linux sound on zt1190

kankanhu, can you post the url for how to get sound/acp?? working? Ive been trying for some weeks now, and still get the repeating sound, and errors when trying to load acpi (no tables found).

Many Thanks
kankanhu
Occasional Advisor

Re: linux sound on zt1190

Here is a excerpt from the original post on the newsgroup, thanks for the geneous author (however, I lost his name :(

BTW, for me, I am using 2.4.18 kernel without any patch. However, till now, only partial of the acpi works. so if you fully nailed down the acpi problem, do let me know.

Hope it helps.


> I got sound and ACPI working on my zt1130 by forcing the ACPI code to
> treat the FADT table as pre ACPI 2.0. In
> src/linux/drivers/acpi/tables/tbconvrt.c, around line 211, force the
> comparison to always be false:
>
> if (0 && acpi_gbl_FADT->header.revision >= FADT2_REVISION_ID) {
> /* We have an ACPI 2.0 FADT but we must copy it to our local buffer
> */
>
> The FADT doesn't contain the 64 bit ACPI 2.0 pointers that the code
> expects. Not sure if this is against the spec, but the code doesn't
> allow for it. Also not sure how the ACPI affects the sound, but it does.
Hauke Busch
Occasional Visitor

Re: linux sound on zt1190

Hi,

finally I got acpi working last week. The problem seems to be the check of the FADT headers. In order to get ACPI working, check out the pages by Stefan bellon. http://www.sbellon.de/xt1000.html
He talks about a xt1000 model, but I think the zt's are the US American equivalents of the European XT models. So the advice should apply to you as well. There you can find a patch you must apply to above mentioned tbconvt.c code
Once ACPI is working, alsa and the kernel sound modules start working like a charm.


Cheers,
Hauke


kankanhu
Occasional Advisor

Re: linux sound on zt1190

however, when I first patch acpi in 2.4.18 kernel with the patch released on 4/4/2002 and then applied the patch on that FADT thing, the acpid will not work then ( I downloaded the newest acpid from the sourceforge and recompiled it).
it says:
acpid: this kernel does not support proper event file handling.
Please get the patch from http://acpid.sourceforge.net

If I use the acpi without the newest patch from sourceforge, this problem will not happen, although in that case the acpi is only partilally supported.

BTW, I am using zt1180. not sure whether that's the problem.