cancel
Showing results for 
Search instead for 
Did you mean: 

login screen not showing

SOLVED
Go to solution
Omar Alvi_1
Super Advisor

login screen not showing

Hi,

I just completed my first Redhat Linux (7.3) installation. On rebooting, just before reaching the login prompt, my screen starts flashing.

I then get this message (screen stops flashing)

INIT: Id "x" respawning too fast: disabled for 5 minutes

Its probably a video card problem.

How do I tackle this, with and/or without reinstallaing (recovery shell, probing etc.)

Thanks a lot.

Regards,

-Alvi
10 REPLIES
Huc_1
Honored Contributor

Re: login screen not showing

What may help is hitting the >ALT>
or any other up to this should get you to a login prompt.

Login as root and from there redo the X setup this can be done using the setup command or xf86config.

Generaly it is a good idea to have a look/search at RH web site to find out if there is a problem with your video card, If you still have problem doing the setup, post a bite more info here and someone (maybe me) will probably be able to help some more.

J-P
Smile I will feel the difference
Omar Alvi_1
Super Advisor

Re: login screen not showing

Hi Huc,

Thanks for the help. I'll try it out if I'm not able to configure the graphics card even after my second installation.

I have builtin graphics card on the motherboard of my HP BRIO BA410 machin, however I don't know the exact graphics card. I saw the graphics card configuration screen (in installation) suggests probing the hardware. Is this meant literally, or is there a way to view the card make through redhat?

Thanks again, I'm in my practice phase of installaing the lab (36 workstations and 1 server)... will work with kickstart later.

-Alvi

Huc_1
Honored Contributor

Re: login screen not showing

Alvi, have a look/read this link
http://www.europe.redhat.com/documentation/HOWTO/HP-HOWTO/hp-hardware.php3
This may help you determine the video card on your motherbord, and get you rolling.

J-P
Smile I will feel the difference
Mark Grant
Honored Contributor
Solution

Re: login screen not showing

Omar, You can often find out exactly what video card you have by "cat /proc/pci". In the meantime, while you are trying to configure X, you might want to turn off the annoying "respawning" message but looking for the X entry in /etc/inittab and changing the "respawn" to "off". You can always change it back when you haved fixed everything.
Never preceed any demonstration with anything more predictive than "watch this"
Omar Alvi_1
Super Advisor

Re: login screen not showing

Thanks a lot, cntrl-Alt-F[1-6] wrks as does cat /proc/pci. Thanks a lot.

Searching on the net I found the vga card model for my PC, and reinstalled 7.3 successfully.

However, now I wanted to try and NOT configure X at installation, and configure it from the command line after booting (for cases where I am unable to get the video card make and model)

So I did as follows

-checked "Skip X configuration" on installation
- after logging in I ran cat /proc/pci to get my VGA card model
- xf86config

Now here I thought I needed to configure only my graphics card, but it went through all other hardware configuration as well :(

Anyway, after somehow completing the setup, I can't figure out how to start X or go to my Gnome GUI.

Is there a good guide for xf86config, or X setup from the command line.

Thanks,

Will assign a couple of "magic answers" but for now need to keep this thread open. Queries abound!!!

-Alvi
Alexander Chuzhoy
Honored Contributor

Re: login screen not showing

in version 7.3 there was a tool
Xconfigurator
simply run it from command line
Huc_1
Honored Contributor

Re: login screen not showing

Alvi,
if you card is now configured to start x from console just type
#startx

If you want to make the start automatic for the next boot then you have to modifie the /etc/inittab and set the
id:3:initdefault:
to
id:5:initdefault:
you should have the following on your system?
/usr/share/doc/XFree86-4.3.0

Hope this helps

J-P
Smile I will feel the difference
Patrick Van Humbeeck
Valued Contributor

Re: login screen not showing

If you're running a recent XFree86 then you dont need any tools to autodetect the hardware, just running X -setup (or was it -configure ?) will probe the system and build a default XF86config file. It will also give you a command line that you can run to test this new config file, run it and check that X comes up ok. if it does, kill X (ctrl-alt-backspace) and copy this config file to /etc/X11/ and you should be all set.

In my experience this works great, you only have to add the video modes you want to use manually afterwards (unless you're fine with the default, which is the highest res. your setup can take I believe).
Omar Alvi_1
Super Advisor

Re: login screen not showing

Well this Xconfigurator was excellent. I was wondering whether this is a standard tool available in the latest versions of redhat as well.


I didn't find the file /usr/share/doc/XFree86-4.3.0

and finally from Patricks post can I conclude that the graphics card configuration no longer requires manual intervention (knowing the model).

Thanks and regards,

-Alvi

points coming soon.
Lisa Nelson_2
Occasional Visitor

Re: login screen not showing

In RedHat 9.0 there is a config program called redhat-config-xfree86 But on my system I had to delete the /etc/X11/XF86Config file first because it must have been trying to use it and would fail to setup X. After that it worked great.