cancel
Showing results for 
Search instead for 
Did you mean: 

lp printing in 11i

Dean Ross-Smith
Occasional Advisor

lp printing in 11i

We are hooking up new printers (kodak/minolta) as remote printers using hppi and using net_genericprinter. We have output and can print portrait and landscape. Things are looking good. Only issue is that we have a carriage return/line feed issue where every line is double spaced but the original files (straight ascii text dumps) are single spaced. There's no other weirdness like stairstepping- everything looks good except for the double spacing issue.
Ideas anyone?
3 REPLIES
Dennis Handly
Acclaimed Contributor

Re: lp printing in 11i

It seems you have the different problem than stair stepping, you have too many linefeeds.

I assume the original files have just linefeeds and they aren't DOS with CR LF?
Bill Hassell
Honored Contributor

Re: lp printing in 11i

Since you set them up using hppi, there is no Windows box in the middle (which is a good thing). However, some printers have internal configurations for Unix compatibility. Unix systems will typically send ASCII files exactly as they are stored: a line feed (LF) at the end of every line but no carriage return (CR). When this is sent to most printers, the result is that the text looks like stairs, dropping down as the text goes across the page.

The hppi model scripts will add the CR after every LF but if your printer is configured for Unix compatibility, you may be getting an extra line from the printer.

To verify this, use the network printer interface program: hpnpf. To send just the raw ASCII files with no special processing, use this:

hpnpf -x 12.34.56.78 /etc/profile

On most printers, this will stairstep across the page and off the right edge of the paper. But if your printers show the text single spaced and normal, then the printers are supplying an extra CR/LF pair. To fix this, use the printer's setup menu and turn off the special Unix option. This might not be called Unix -- it might be some other OS name.

Now if these printers are being used by other systems, turning off this setting in the printer may break printouts from those systems. In that case, get a copy of the technical refence manual and find the special codes that can be pre-pended to each job to set the printer correctly for HP-UX.


Bill Hassell, sysadmin
Dean Ross-Smith
Occasional Advisor

Re: lp printing in 11i

ok, fixed it. It wasn't a spacing issue at all... Turns out the printers have a default setting for lines per page in pcl settings. So setting the pcl pitch for smaller fonts still keeps the 60 lines per page, looking like the output was double spaced. We set the font pitch for 13 and the lines per page at 72 (this is a konica minolta bizhub printer) and set the printer up in hppi using a net_genericprinter model script. All of this gets us portrait, landscape and 132 column output in landscape on 8.5 x 11 paper. The only other thing we tested was that bold works too. This is an office printer and is used by windows, macs and my hp 9000 series box running hpux 11.11.