Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

lsof building

Alfredo Raymundo
Contributor

lsof building

I downloaded the lsof source, while using ./Configure i got the following error:

Looking for ipis_s with /usr/contrib/bin/q4 ...

!!!ERROR!!! /usr/contrib/bin/q4 failed and produced the following output.

q4: (warning) no modules in the crashdump or no INDEX file
q4: (error) vmunix not pxdb'd

!!!ERROR!!! !!!ERROR!!! !!!ERROR!!! !!!ERROR!!!
Configure can't use /usr/contrib/bin/q4 to examine the ipis_s
structure. You must do that yourself, report the result in
the HPUX_IPC_S_PATCH environment variable, then repeat the
Configure step. Consult the Configure script's use of
/usr/contrib/bin/q4 and the 00XCONFIG file for information
on ipis_s testing and the setting of HPUX_IPC_S_PATCH.
!!!ERROR!!! !!!ERROR!!! !!!ERROR!!! !!!ERROR!!!
3 REPLIES
A. Clay Stephenson
Acclaimed Contributor

Re: lsof building

You have two choices:

1) Download and install q4; it's a good tool to have.

2) Modify the makefile to not look at the q4 stuff.
If it ain't broke, I can fix that.
Sridhar Bhaskarla
Honored Contributor

Re: lsof building

Hi Alfredo,

We already had a discussion on building lsof. Check the following thread for details.

http://forums.itrc.hp.com/cm/QuestionAnswer/1,,0x15eaf715edc6d5118ff10090279cd0f9,00.html

I did post a solution. But one that was posted by Ramesh looked better.

-Sri
You may be disappointed if you fail, but you are doomed if you don't try
Steven Gillard_2
Honored Contributor

Re: lsof building

Q4 requires q4pxdb to be run before it can be used. Its not recommended to do this on the running kernel, however, so copy it to /tmp first. Try this:

1. cp /stand/vmunix /tmp
2. q4pxdb /tmp/vmunix
3. Edit the Configure script, find the line where q4 is called and change /stand/vmunix to /tmp/vmunix.

Then try running Configure again.

Regards,
Steve