General
cancel
Showing results for 
Search instead for 
Did you mean: 

mandrake and tape drive configuration (ML370)

SOLVED
Go to solution
Siva Kondepati
Occasional Contributor

mandrake and tape drive configuration (ML370)

unable to make mandrake recognize the dat tape drive. bios was able to detect but OS is not recognizing.
Any help in this regard is really appreciated.
Thanks,
-Siva
5 REPLIES
Stuart Browne
Honored Contributor

Re: mandrake and tape drive configuration (ML370)

Has the OS configured the SCSI controller? Check the contents of '/proc/scsi/scsi' to check.

It may be as simple as just inserting the tape module (modprobe st).

If not, first thing you need to do is get the controller recognised. From memory an ML370 has a 'aic7xxx' based controller. Try inserting that (modprobe aic7xxx) and see if it sticks.

I've not configured mandrake before, so am not sure what 'tools' it is distributed with to do the auto-configuration of devices for you (RH uses 'kudzu'), but you'll then just need to add the modprobe lines to one of your startup files.
One long-haired git at your service...
Siva Kondepati
Occasional Contributor

Re: mandrake and tape drive configuration (ML370)

Thanks for your reply.
I tried using lsmod and i found
scsi_mod but not the st.
So, i loaded st using modprobe.
and then i had dmesg but could not find anything related to tape drive.

Then i executed lsmod again to see whether the st module is loaded and i found st in the list.
and when try to load aic7xxx, it's saying could not find.
Do i need to load any specific module from compaq to have (ML370) server compaq dat 12/24 tape drive to work on mandrake??
Thanks and waiting for a reply,
-Siva
Stuart Browne
Honored Contributor

Re: mandrake and tape drive configuration (ML370)

No, you shouldn't need to.

Which SCSI bus is the tape drive plugged in to?

What does it say in the POST. Also, what does the contents of '/proc/scsi/scsi' say?
One long-haired git at your service...
Siva Kondepati
Occasional Contributor

Re: mandrake and tape drive configuration (ML370)

the contents of '/proc/scsi/scsi' are:
attached devices:none

in the POST, it started with "smart 2 controller" blinking and then had a message like
"compaq 12/24 DAT tape drive" and said some details like device, port, SCSI...

I don't know to which SCSI bus is the tape drive plugged in. As, it is a web server which is running most of the time, we didnot open the cabinet.
thanks,
-Siva

Stuart Browne
Honored Contributor
Solution

Re: mandrake and tape drive configuration (ML370)

Righteo!

It's sounding like you've got an old-model ML with the older SmartArray series of controller using the 'cpqarray' driver.

It also appears as if the tape is plugged into this array controller.

Have a read through this thread:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?threadId=541892

It's pretty much the same thing. If you have another SCSI controller in the machine (I think you will, the output of 'lsmod' will help confirm this), move the tape to a different SCSI controller.
One long-haired git at your service...