General
cancel
Showing results for 
Search instead for 
Did you mean: 

mdtm command on HP-UX B.11.23 U ia64

SOLVED
Go to solution
Domenico Viggiani
Super Advisor

mdtm command on HP-UX B.11.23 U ia64

we have an itanium system running HP-UX B.11.23 , when we open a ftp session and try to run the command "quote mdtm " an incorrect data is displayed.
Somethings about GMT and localtime.
Can help us?
thanks in advance
6 REPLIES
Suraj K Sankari
Honored Contributor

Re: mdtm command on HP-UX B.11.23 U ia64

Hi,
Could you post the screen shot what are you getting the error messages.

Suraj
Domenico Viggiani
Super Advisor

Re: mdtm command on HP-UX B.11.23 U ia64

220 myserver FTP server (Revision 1.1 Version wuftpd-2.6.1 Fri Jul 16 19:08:11 GMT 2004) ready.
Name (myserver: user): user
331 Password required for user.
Password:
230 User user logged in.
Remote system type is UNIX.
Using binary mode to transfer files.
ftp> dir myfile
200 PORT command successful.
150 Opening ASCII mode data connection for /usr/bin/ls.
-rw-rw-rw- 1 user users 36335 May 18 10:35 myfile
226 Transfer complete.
ftp> quote mdtm vr.txt
213 20090518083525
ftp>



the date displayed by command mdtm "20090518083525" is 2 hours earlier than date displayed using command ls
smatador
Honored Contributor

Re: mdtm command on HP-UX B.11.23 U ia64

Hi,
perhaps, if it like vsftpd you could try in adding the use_localtime config option to override the use of GMT times.
use_localtime=YES
http://www.ph-lwug.org/node/570
So now, the deal is to know if this variable exist on wu-ftpd.
Hope it helps
Domenico Viggiani
Super Advisor

Re: mdtm command on HP-UX B.11.23 U ia64

I have not experience about unix operating system. where is configuration file? there isnt file: /etc/vsftpd.conf , just i have an entry in /etc/services and in /etc/inetd.conf
smatador
Honored Contributor
Solution

Re: mdtm command on HP-UX B.11.23 U ia64

Hi,
I make some more search about this, and it seem it's impossible with wuftpd to interact like with vsftpd, no use_localtime
http://wu-ftpd.therockgarden.ca/man/ftpd.html

You could now choose to
1 - try proftpd
http://hpux.connect.org.uk/hppd/hpux/Networking/FTP/proftpd-1.3.2/
the explanation of the timestamp and the solution to pass it with SITE_UTIME
http://www.proftpd.org/docs/howto/Timestamps.html

2 - try to compile vsftpd for 11.23
http://vsftpd.beasts.org/

Hope it helps
Domenico Viggiani
Super Advisor

Re: mdtm command on HP-UX B.11.23 U ia64

thanks for support