cancel
Showing results for 
Search instead for 
Did you mean: 

multipath and XP1024

Denis Zoccarato
Occasional Contributor

multipath and XP1024

Hi,

we have a BL20p G3 with two Qlogic HBA connected on a XP1024 and as Operating System SUSE SLES 9 SP3. With hp_qla driver the multipath works fine and from SANsurfer we can see every LUN with a unique WWULN. Now we are trying to use the multipath tools according to the document "Device Mapper Configuration Guide for HP Array" but I don't understand if it works fine.We have 2 LUN but from the command multipath -ll I see 4 LUN with diffent WWID:
...
0HP_OPEN-E_50060e800329e20500010000000000000000e000
[size=13 GB][features="1 queue_if_no_path"][hwhandler="0"]
\_ round-robin 0 [prio=1][enabled]
\_ 0:0:0:1 sdb 8:16 [active][ready]

0HP_OPEN-E_50060e800329e21500000000000000000000c700
[size=13 GB][features="1 queue_if_no_path"][hwhandler="0"]
\_ round-robin 0 [prio=1][enabled]
\_ 1:0:0:0 sdc 8:32 [active][ready]

0HP_OPEN-E_50060e800329e21500010000000000000000c700
[size=13 GB][features="1 queue_if_no_path"][hwhandler="0"]
\_ round-robin 0 [prio=1][enabled]
\_ 1:0:0:1 sdd 8:48 [active][ready]

0HP_OPEN-E_50060e800329e20500000000000000000000e000
[size=13 GB][features="1 queue_if_no_path"][hwhandler="0"]
\_ round-robin 0 [prio=1][enabled]
\_ 0:0:0:0 sda 8:0 [active][ready]

How can I identifier the LUN if there are 4 different WWID? From SANsurfer I saw the same LUN from HBAs with the parameter WWULN. Can I use the same parameter on /etc/multipath.conf ?

Thanks in advance,

Denis
1 REPLY
Alan_152
Honored Contributor

Re: multipath and XP1024

I have been finding that for SLES the latest versions of the QLA driver and SanSurfer from the QLA website take care of these problems much better than the HP versions.