Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

mysql 3.23.52 installation dependancy

Leigh Peterson
Occasional Advisor

mysql 3.23.52 installation dependancy

Hi All,

I apologise if this question has already been posted somewhere. I'm having some problems installing the mysql 3.23.52 depot. When I try to install it, I get the following warning:

'The software "mysql,r=3.23.52,a=HP-UX_B.11.00_700/800,v=" was
successfully marked, but it depends on the following software items
which could not be found in the source. However, these items may
already be in the target. This will be checked during the Analysis
Phase: gcc.gcc-SHLIBS guile.guile-SHLIBS'

Can someone please tell me what I have to install to meet these dependencies? I have already installed GNU gcc.

Any help would be much appreciated.

Regards,
Leigh
22 REPLIES
Chuck J
Valued Contributor

Re: mysql 3.23.52 installation dependancy

Leigh

Did you run the analysis? Sometimes i've found the software it required was already installed on the server by the OS install. If the analysis succeeds then you can go ahead and install your software without any problems.

Chuck J
Balaji N
Honored Contributor

Re: mysql 3.23.52 installation dependancy

Hi,
According to the HP unix porting archive, the only dependency for the mysql depot is the ncurses library. Do u have it installed?

Check out the link below.
http://hpux.connect.org.uk/hppd/hpux/Development/Languages/mysql-3.23.52/

Hope this helps.
-balaji
Its Always Important To Know, What People Think Of You. Then, Of Course, You Surprise Them By Giving More.
Clemens van Everdingen
Honored Contributor

Re: mysql 3.23.52 installation dependancy

Hi,

During the next step in installing mysql you will have to run the analysis phase.
Do you get any error or warning then ?
If you have installed gcc then there will be no problem at all during analysis and you will be able to succesfully install mysql.

C.
The computer is a great invention, there are as many mistakes as ever, but they are nobody's fault !
Leigh Peterson
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Hi All,

Thanks for your prompt responces. To answer some of your questions, yes I still get the error warnings when I go to the analysis stage of the install. I have attached the analysis log that was produced by swinstall. Again, any pointers would be much appreciated.

Regards,
Leigh
Clemens van Everdingen
Honored Contributor

Re: mysql 3.23.52 installation dependancy

Hi,

Could you check this:

swlist -l fileset|grep -i gcc

Please post the output.

C.
The computer is a great invention, there are as many mistakes as ever, but they are nobody's fault !
Leigh Peterson
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Hi Clemens,

The output to that command is:

root@[/home/leigh]swlist -l fileset|grep -i gcc
# gcc 3.0.4 gcc
gcc.gcc-INC
gcc.gcc-MAN
gcc.gcc-RUN

Am I correct in assuming that the shared library component of gcc has not been installed or was not part of the depot that I installed? I did the same command and grepped for "guile" and it seems that it's not installed on the system. If I install the guile depot from http://hpux.connect.org.uk/hppd/hpux/Gnu/guile-1.4/, am I likely to find that it also will not install the SHLIBS component?

Regards,
Leigh
Clemens van Everdingen
Honored Contributor

Re: mysql 3.23.52 installation dependancy

Hi,

Indeed it looks like the SHLIBS are not installed.

By the way I would try to install this version.

http://hpux.connect.org.uk/hppd/hpux/Gnu/gcc-3.1/

Also install guile from the previous link.

C.
The computer is a great invention, there are as many mistakes as ever, but they are nobody's fault !
Leigh Peterson
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Well,

That solved half my problem - the gcc3.1 depot included the gcc.gcc-SHLIBS package. However, the guile-1.4 depot did not contain the guile.guile-SHLIBS package and mysql still fails to install. Any idea where I can get another guile depot?

Regards,
Leigh
Clemens van Everdingen
Honored Contributor

Re: mysql 3.23.52 installation dependancy

Hi,

I could not find any hp-ux depot !
See here for the sources:

http://www.gnu.org/software/guile/guile.html

maybe you wil be able to compile them on your system.

C.
The computer is a great invention, there are as many mistakes as ever, but they are nobody's fault !
Mehdi_1
Regular Advisor

Re: mysql 3.23.52 installation dependancy

Hi
Are you still experienceing any problem?

If you have please email me :

lavasani@connect.org.uk

I will try to solve the problem.



ps: I am the porter of the above packages on HPUX Archive.
aaa_17
Advisor

Re: mysql 3.23.52 installation dependancy

Hi Leigh,

I faced the same senario during the mysql installation. However, I can't find the version 3.1 of gcc compiler in the below URL, Can u tell me how I can get this version of gcc? Thanks!
Leigh Peterson
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Hi aaa,

Looks like version 3.1 of the GCC compiler is no longer on the site. You can download the latest version (3.2.3) here http://hpux.connect.org.uk/hppd/hpux/Gnu/gcc-3.2.3/
or version 3.2 here http://hpux.connect.org.uk/hppd/hpux/Gnu/gcc-3.2/

Guile is available here http://hpux.connect.org.uk/hppd/hpux/Gnu/guile-1.6.0/

Regards,
Leigh
Clemens van Everdingen
Honored Contributor

Re: mysql 3.23.52 installation dependancy

Leigh,

Did you try these pages for more information ?

http://www.cmve.net/~merijn/#Gcc

Procura did a wonderfull job there .

Kind regards,
Clemens
The computer is a great invention, there are as many mistakes as ever, but they are nobody's fault !
Paul Debleecker
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Hi,

I'm having the same problem on my systems as well.
I have already installed following packages:
ncurses-5.3-sd-11.00.depot
openssl-0.9.7b-sd-11.00.depot
gcc-3.3.1-sd-11.00.depot
glib2-2.2.2-sd-11.00.depot
and some other packages as well.

I am currently having problems installing mysql-3.23.55-sd-11.00.depot
My main goal is to get apache running with php
When I type ./httpd -v I get following error message:
/usr/lib/dld.sl: Can't open shared library: /usr/local/mysql/lib/mysql/libmysqlc
lient.sl.10
/usr/lib/dld.sl: No such file or directory
Abort(coredump)

Maybe I need another gcc to get things up and running?

Best regards,
Clemens van Everdingen
Honored Contributor

Re: mysql 3.23.52 installation dependancy

Hi,

Check in /etc/SHLIB_PATH if the path to the shared libs are there.
I got recently the same issue with an installation of netscape directory server.

First do a find on the files the system is complaining about, and then chekc if the path to these files is in the mentioned file.
Also check for other stuff if the path is in /etc/PATH.

In thos files you will be able to define the default path's sourced by the .profile.

Clemens
The computer is a great invention, there are as many mistakes as ever, but they are nobody's fault !
Jairo Florez
Occasional Visitor

Re: mysql 3.23.52 installation dependancy

the solutios is: install gcc 3.2, because it has libgcc_s.sl then install the others (new release)
Paul Debleecker
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

I've already did a downgrade from 3.3.1 to 3.2.
I'm still having the same problem. Also gcc 3.2.3 does not solve the problem.
I've contacted the creator of the depot file and he replied to me with the following message:

In regard to mysql-3.23.55, there is a very little chance for you to fix the
problem. The problem is that, few month ago our automatic "depot" builder
program want bugy, and added some dependency to some depot that it shouldn't.
Unfortunatly, mysql depot is one of those depot that got effected. To
fix the problem I have to build another depot. However I decided to build
another depot with the new version of Mysql (4.0.15).


That shouldn't take long. It should be ready in the next few days.
----------------------------------
So, I have to be a little patiened and try to install a more recent version in a few days.

Bye,

Paul Debleecker
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Version 4.0.15 is available for download.
With this new version, I did not had any problem with the installation.

Regards,
Matti Yrjölä
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Regarding the mysql-4.0.15a:

I have a problem with the new mysql-4.0.15a package downloaded from:
http://hpux.connect.org.uk/hppd/hpux/Development/Languages/mysql-4.0.15a/

When I try to run mysql (or mysqld) it complains about missing
shared library:

/usr/local/mysql/bin/mysql
/usr/lib/dld.sl: Can't find path for shared library: libstdc++.sl.5
/usr/lib/dld.sl: No such file or directory
Abort

I have installed gcc 3.3.1 (and other required packages) from Software Porting And Archive Centre for HP-UX but the libstdc++.sl.5
shared library is missing. Is this a problem with the gcc or mysql
package?


$ gcc -v
Reading specs from /usr/local/lib/gcc-lib/hppa2.0n-hp-hpux11.00/3.3.1/specs
Configured with: ./configure --prefix=/usr/local --exec-prefix=/usr/local
+--disable-threads --disable-shared --with-gnu-as --enable-languages=c,c++,f77
+--disable-nls
Thread model: single
gcc version 3.3.1

$ uname -a
HP-UX lib B.11.11 U 9000/800 1729987641 unlimited-user license
Matti Yrjölä
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Does anybody else have this problem (see my previous message) with the MySQL 4.0.15a from Software Porting And Archive Centre for HP-UX.

I have emailed hpux@connect.org.uk but so far no reply.

Getting bit frustrated as the HP Web Server Suite (Apache 2, PHP 4.2.3) has a PHP version with a serious bug in it and is also compiled with MySQL 3.23 client API).
The PHP bug in PHP 4.2.3 causes some file/directory functions to fail when used together with relative file/directory paths.

For example following call fails:
if (!file_exists( "configuration.php" )) {

But this works when absolute path is given:
if (!file_exists("/opt/Mambo4.5/configuration.php" )) {


This PHP bug in PHP 4.2.3 is also documented at:
http://bugs.php.net/bug.php?id=19287

I have also confirmed this issue trough HP support and the bug has been acknowledged but they got information that a new version of HP Web Serve Suite is only coming early next year!

So if you have installed HP Web Server Suite and are using PHP scripts better watch out.


I am trying to get Apache (preferably Apache 2) with SSL, PHP and MySQL running but getting bogged down with the shared library dependencies.

Any good ideas?


Mehdi_1
Regular Advisor

Re: mysql 3.23.52 installation dependancy

Hi

I am sorry, but the mysql-4.0.15a depot has problem!!. It is linking to a library that it shouldn't. I am the person who build that depot file. I can't help you, since I am no longer with HP Porting Center. The new depot file has to be made. you should email hpux@connect.org.uk, you may get some response.

Mehdi
Matti Yrjölä
Occasional Advisor

Re: mysql 3.23.52 installation dependancy

Ok, thx for the info Mehdi, I appreciate it!

Matti