Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

mysql cannot run with HP-UX 11.0

Kenneth_61
Frequent Advisor

mysql cannot run with HP-UX 11.0

My HP-UX 11.0 box running well. I had tried 3 days , but still cannot install mysql. I had tried version mysql 4.0.15a, 4.1.12 max and 5.0.4 beta standard. Still have the following error. What can I do ? How to add the default search path /usr/local/mysql/bin ? I just know PATH=$PATH:/usr/local/mysql/bin and EXPORT PATH. I had follow the mysql manual and read back and forth. Error still.

Error :
# pwd
# /usr/local/mysql/support-files
# ./mysql.server start
Starting MySQL
................................... ERROR!

# swlist
# Initializing...
# Contacting target "server.mydomain.com"...
#
# Target: server.mydomain.com:/
#

#
# Bundle(s):
#

BIND-920 B.11.00.01.003 BIND 9.2.0
BUNDLE B.11.00 Patch Bundle
HPUXEng32RT B.11.00.01 English HP-UX 32-bit Runtime Environment
Sendmail-811 B.11.00.01.005 Sendmail-8.11.1 special release upgrade
UXCoreMedia B.11.00.01 HP-UX Media Kit (Reference Only. See Description)
XSWGR1100 B.11.00.47.08 General Release Patches, November 1999 (ACE)
hpuxwsApache A.2.0.52.00 HP-UX Apache-based Web Server
hpuxwsTomcat A.4.1.29.04 HP-UX Tomcat-based Servlet Engine
hpuxwsWebmin A.1.070.02 HP-UX Webmin-based Admin
#
# Product(s) not contained in a Bundle:
#

PHCO_26111 1.0 libc cumulative header file patch
PHCO_27847 1.0 cumulative patch for syslogd(1M)
PHCO_29286 1.0 libc cumulative man page patch
PHCO_29330 1.0 libc configuration file patch.
PHCO_29956 1.0 libc cumulative patch
PHSS_30967 1.0 ld(1) and linker tools cumulative patch
mysql 4.0.15a mysql
mysql-max 4.1.12 MySQL Community Edition - Experimental (GPL)
mysql-standard 5.0.4-beta MySQL Community Edition - Standard (GPL)
qpopper 4.0.5 qpopper
5 REPLIES
Alzhy
Honored Contributor

Re: mysql cannot run with HP-UX 11.0


Have you tried the MySQL that is bundled with Internet Express over at software.hp.com? It is supposed to be for HP-UX 11i v1.0 but who knows... it might work under 11.0.

All of my MySQL configurations use the as-shipped (with 11.11) release and bundled with the OS and have recently upgraded from the Internet Express bundle.

I've stoppped building our own GNU/OpenSource tools and have instead been relying HP built ones since I also get official support from HP. These are.. SSH, TCPWRAPPERS, SUDO, Apache, PHP, etc..


Hakuna Matata.
Steven E. Protter
Exalted Contributor

Re: mysql cannot run with HP-UX 11.0

Nelson is right.

I have been told that significant changes had to be made to port mysql to HP-UX.

Therefore the only viable, easy option for mysql is the Internet Express version which has been ported and is in depot form.

I'm running it on a few 11i machines and trying to develop some ServiceGuard high availability scripts for it.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Alex Lavrov.
Honored Contributor

Re: mysql cannot run with HP-UX 11.0

If you do:
sh -x ./mysql.server start


which line causes the error?

Alex.
I don't give a damn for a man that can only spell a word one way. (M. Twain)
Kenneth_61
Frequent Advisor

Re: mysql cannot run with HP-UX 11.0

# sh -x ./mysql.server start
+ basedir=
+ datadir=
+ pid_file=
+ server_pid_file=
+ use_mysqld_safe=1
+ user=mysql
+ test -z
+ basedir=/usr/local/mysql
+ bindir=./bin
+ datadir=/usr/local/mysql/data
+ sbindir=./bin
+ libexecdir=./bin
+ lsb_functions=/lib/lsb/init-functions
+ test -f /lib/lsb/init-functions
+ PATH=/sbin:/usr/sbin:/bin:/usr/bin:/usr/local/mysql/bin
+ export PATH
+ mode=start
+ echo testing\c
+ echo -n testing
+ echo_n= echo_c=\c
+ test -x ./bin/my_print_defaults
+ test -x ./bin/my_print_defaults
+ test -x ./bin/mysql_print_defaults
+ conf=/etc/my.cnf
+ print_defaults=
+ test -r /etc/my.cnf
+ test -z
+ print_defaults=my_print_defaults
+ extra_args=
+ test -r /usr/local/mysql/my.cnf
+ test -r /usr/local/mysql/data/my.cnf
+ my_print_defaults mysqld server mysql_server mysql.server
+ parse_server_arguments
+ my_print_defaults manager
+ parse_manager_arguments
+ test -z
+ + /usr/bin/hostname
pid_file=/usr/local/mysql/data/mysqlmanager-server.mydomain.com.pid
+ test -z
+ + /usr/bin/hostname
server_pid_file=/usr/local/mysql/data/server.mydomain.com.pid
+ cd /usr/local/mysql
+ manager=./bin/mysqlmanager
+ test -x ./bin/mysqlmanager
+ test -x ./bin/mysqlmanager
+ echo Starting MySQL
Starting MySQL
+ test -x ./bin/mysqlmanager -a 1 = 0
+ test -x ./bin/mysqld_safe
+ pid_file=/usr/local/mysql/data/server.mydomain.com.pid
+ ./bin/mysqld_safe --datadir=/usr/local/mysql/data --pid-file=/usr/local/mysql/data/server.mydomain.com.pid
+ 1> /dev/null 2>& 1
+ wait_for_pid created
................................... ERROR!
+ test -w /var/lock/subsys
Kenneth_61
Frequent Advisor

Re: mysql cannot run with HP-UX 11.0

Yeah ! I know the reason now. The reason is due to the rights on /usr/local/mysql/data/mysql ! In the mysql manual, it just say:

shell> chown -R root .
shell> chown -R mysql data
shell> chgrp -R mysql

But, I found that the user ID mysql have no rights on /usr/local/mysql/data/mysql ! It makes the makes the program cannot read help_relation.frm in that directory.

Problem solve now. Thanks for all.