cancel
Showing results for 
Search instead for 
Did you mean: 

netraid on netserver lh 4r

Kim Kendall
Regular Advisor

netraid on netserver lh 4r

Wanted to load linux, but am having difficulty identifying my specific raid card and thus the appropriate driver

NetServer LH 4r (Model D7095A)

On boot, it says:

HP Netraid adapter bios B.02.03 Nov 02,2000
Copywrite Amereican Megatrends

What is this card and where can I get the drivers (and/or firmware)
6 REPLIES
Stuart Browne
Honored Contributor

Re: netraid on netserver lh 4r

The NetRAID onboard in the LH3/4 series of server is a modified "American Megatrends MegaRAID" controller. The exact model isn't required, as all of the MegaRAID controllers use the same driver ('megaraid').

If you are using a recent installation (i.e. less than 2 years old), it should be detected automatically.

From memory however it's something like a "MegaRAID Express 500" or some such. In any case, that entire series of card uses the same driver.
One long-haired git at your service...
Bill Douglass
Esteemed Contributor

Re: netraid on netserver lh 4r

You can get more info on the megaraid driver and the versions available in various RH Linux releases at

http://www.domsch.com/linux/
Kim Kendall
Regular Advisor

Re: netraid on netserver lh 4r

I get a refused connection when I try that site. Where else can I get the driver?
Kim Kendall
Regular Advisor

Re: netraid on netserver lh 4r

See the attached file....

Not all of these MegaRaid choices have the same driver. I'd really like to know how to tell just what is installed in this system.
Bill Douglass
Esteemed Contributor

Re: netraid on netserver lh 4r

There is just one Megaraid driver for Linux that I know of.

From the LSI web site, select one of the Megaraid cards (not the ATA one), then click on the Linux version you have. You should get the version 1.18 driver, in a compressed tar file.

What distribution and version of Linux are your using.
Kim Kendall
Regular Advisor

Re: netraid on netserver lh 4r

I wanted to load Red Hat. I've tried 7.1, 8.0, and ES so far (even tried Suse Pro 7.3 and Enterprise 7.0).

I got the 118H driver and put the image onto a floppy. With the RH, it appeared to load the driver just fine. When it asked for the type of install (RH 7.1) (server, custom, etc) it errored that there weren't any valid devices.

With RH ES, it got past that, to where I tried to select the disk partitioning method, I got the same error.