General
cancel
Showing results for 
Search instead for 
Did you mean: 

new kernel does not load any modules

chaitanya_2
Occasional Contributor

new kernel does not load any modules

Hi,
When i compile the 2.4.2 kernel on RH 7.1, none of the modules are being loaded. lsmod shows an empty list. The /lib/modules/2.4.2/ directory does not contain any of the modules (except for a dummy.o module in drivers/net).
The steps i used to compile the kernel are
1) make mrproper
2) make xconfig
3) make clean
4) make bzImage
5) make modules
6) make modules_install
7) edit lilo etc.

Can someone tell me what the problem is ?
Thanks,
Chaitanya
5 REPLIES
Charles Slivkoff
Respected Contributor

Re: new kernel does not load any modules

Did you enable module support?

CONFIG_MODULES=y

Did you include all your drivers built-in to your kernel?

What modules did you build?

# grep =m$ /usr/src/linux/.config

Will modules load manually using "modprobe" or "insmod"?
chaitanya_2
Occasional Contributor

Re: new kernel does not load any modules

hi chuck,
> Did you enable module support?
>CONFIG_MODULES=y

yes. I checked the .config file and it is enabled
> Did you include all your drivers >built-in to your kernel?

yes. (i chose 'y' instead of 'm' for any modules that i included)
> What modules did you build?

some sound modules
> # grep =m$ /usr/src/linux/.config

When i ran this command the output was
CONFIG_DUMMY=m
> Will modules load manually using >"modprobe" or "insmod"?

when i try to do insmod, it says
module name:no module by that name found. makes sense i think as
/lib/modules/linux/drivers is empty

one more thing i noticed was that when I do make bzImage, the corresponding driver sources are getting compiled. But when I do a make modules the modversions.h is not being updated for those drivers.

And when i do make modules_install,
none of the modules are being copied to the /lib/modules/linux/ directory.

i also have installed latest modutils package but made no difference. (i read somewhere that this could cause the problem).

Hope u can solve my problem with this info
Thanks,
Chaitanya


Jeffrey Wong
Advisor

Re: new kernel does not load any modules

After you run make xconfig (or make config/make menuconfig) you should do a 'make dep' before 'make clean'.
T.Watanabe
Advisor

Re: new kernel does not load any modules

try
# depmod -a
after make modules_install
Stuart Browne
Honored Contributor

Re: new kernel does not load any modules

Given:

> # grep =m$ /usr/src/linux/.config

When i ran this command the output was
CONFIG_DUMMY=m


I'd say that you arn't actually choosing any of the drivers to be made as MODULES, but are compiling them into the kernel instead.

Unless you choose 'Module' (M) when going through 'make config' (or 'menuconfig' or 'xconfig'), it won't make any other modules!

It sounds as if it's behaving perfectly fine given this.
One long-haired git at your service...