cancel
Showing results for 
Search instead for 
Did you mean: 

nfs mount problem

SOLVED
Go to solution
Rita C Workman
Honored Contributor

nfs mount problem

Here's my problem:

Loaded software CD on my 11.11 workstation.
Tried with mount -F cdfs -o cdcase ... /cdrom
But that came out garbled with -1, so remounted using pfs_mount options. Now it's not garbled so I'm happy.
My /etc/exports file looks like this:
/cdrom -anon=2,ro

Did nfs mount from 11.23 PARisc using:
pfs_mount :/cdrom /cdrom
...Mounts & looks fine...

Did nfs mount from 11.23 Itanium using:
pfs_mount :/cdrom /cdrom
...Mounts & looks fine...

Did nfs mount from 11.31 Itanium using:
mount :/cdrom /cdrom

...cause remember there is no pfs_mount on 11.31 Itanium
...Got message:
nfs mount Permission denied

Any suggestions?

Thanks,
Rita
14 REPLIES
Rita C Workman
Honored Contributor

Re: nfs mount problem

Dave Olker where are you?????
Steven E. Protter
Exalted Contributor

Re: nfs mount problem

Shalom Rita,

I think you gave up on mount options to soon.

pfs_mount does not exist on 11.31.

So you need to mount this thing with different options.

http://www.hpux.ws/?p=20

You may need to play, but it should be possible to do this.

Or use dd to copy the thing to disk and then mount it.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Rita C Workman
Honored Contributor

Re: nfs mount problem

Shalom Steven,

I did tried mounting it like that using:
mount -F cdfs -o cdcase /dev/dsk/... /cdrom

It mounts all garbled with the -1 and the filenames all CAPS with 1 at the end. Can't use it to load software from. Can't even open a file with it like that.

Rita
Steven E. Protter
Exalted Contributor

Re: nfs mount problem

Shalom again,

Can you say what kind of sofware we are talking about. I might find something on the provider website.


/etc/exports
/cdrom -anon=2,ro

explicitly permit root mount in there.

/cdrom -root=mngp01

By default root mounts on nfs shares are rejected. Security. Feh.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Patrick Wallek
Honored Contributor
Solution

Re: nfs mount problem

Rita,

You shouldn't need to use the nasty pfs_mount junk any more. You should, with a well patched 11.11 system, be able to use the rock ridge extensions by doing a 'mount -o rr'. I think this should solve your problem.

I have no 11.31 server to I'm not sure about your NFS issue, but try the '-o rr' and see if that helps you.
Steven Schweda
Honored Contributor

Re: nfs mount problem

Lots of old threads on this topic, which a
Forum search for:
mount CD-ROM
should have found. One example:

http://forums.itrc.hp.com/service/forums/questionanswer.do?threadId=1215516


> [...] software CD [...]

Not a very detailed description. Whose
software?

> [...] garbled with -1 [...]

Not a very helpful description.
James R. Ferguson
Acclaimed Contributor

Re: nfs mount problem

Hi Rita:

The last thing, in my opinion, you want is to use the brittle, obsolete, Portable File System (PFS) mechanism.

I would do yourself a favor and install (with a reboot) the following for 11.11:

PHKL_26269
PHKL_37535
PHCO_25841

Once installed, you can forever forget about the 'pfs_mount' and do:

# /usr/sbin/mount -F cdfs -e -o ro,cdcase /dev/dsk/cXtYdZ /cdrom

...and dispense with needing to run some of the NFS daemons, too.

Regards!

...JRF...
Rita C Workman
Honored Contributor

Re: nfs mount problem

Morning All!

To answer:
The garbled was that it was not only showing owner/group as -1, but the files showed as all caps with -1 extension. The files could not even be opened to read.

With that said, my extra mounting options using the cdcase (as I call it) version were obviously lacking. But on the good side, Jim, I actually already had those patches in my 11.11 workstation. So I took down the pfs_mount and the other nfs connections to it and remounted using the syntax provided.

....the other two still remote mount fine, but when I try ran:
mount :/cdrom /cdrom

...now I got:

nfs mount /cdrom Device busy

But when I did:
mount :/cdrom /SD_CDROM

it worked.
So I removed the dir /cdrom and then re-created it. Umounted /SD_CDROM and retried the nfs mount from /cdrom to /cdrom and it worked.

Points a coming!

Rita C Workman
Honored Contributor

Re: nfs mount problem

Thanks all for your help, I will be sure to add the 'correct' syntax to my quickie notes!

Kindest regards to all!
Rita
Dave Olker
HPE Pro

Re: nfs mount problem

Sorry Rita! I typically look at ITRC threads after I get the daily summary email at the end of the day. :)

Feel free to ping me if you need me to look at something urgently: dave.olker@hp.com.

Cheers,

Dave
Rita C Workman
Honored Contributor

Re: nfs mount problem

I thought I should re-open and update this thread.

Turns out the mount options used above do work and the mount command does appear to work for NFS. But when I went out to my 11.31 NFS client and ran 'll' it hangs, never to shows anything as mounted.

The interesting thing is...the NFS mount is actually there! I ran (from the 11.31 client side) to install from the NFS host to the 11.31 NFS client and lo and behold, it installed just fine on the client. No delay, no hangs.
But you simply can not see the NFS filesystem at all on the client side.

Now Mr. Olker (our NFS Guru...) was able to recreate the problem and came up with the following suggestion:

The quick workaround for you would be to mount the filesystem using the â readdirâ mount option. This disables READDIRPLUS for this mount point and falls back to the previous behavior of sending READDIR and LOOKUP calls instead.

He says he will see about sending this up to the lab to address.

So, Mr. Olker, just stop by and add any additional information for folks, should they run into this....and the 10 points are yours!!

Many Thanks Dave,
Regards,
Rita
Rita C Workman
Honored Contributor

Re: nfs mount problem

THREAD CLOSED...
Dave Olker
HPE Pro

Re: nfs mount problem

Here's what I've found so far...

The reason why the "ls" command hangs is because the 11i v3 client gets into a loop calling the same READDIRPLUS call over and over again. It retrieves the first portion of the remote directory contents but never advances its pointer to request the next chunk of the directory. Instead a network trace shows the same request for the first part of the directory contents over and over again.

What's interesting is this same problem happens with Solaris 10 clients. I used the very latest Solaris 10 bits to build a client and I get the identical behavior from that box.

When I use an 11i v3 client running an older version of ONCplus (11.31.04) I don't see this problem, so this makes me think we inherited this problem when we ported the ONC 2.5 client code as part of ONCplus 11.31.06. Sure enough, when I install ONCplus 11.31.06 on my test system the ls command hangs.

I've submitted a CR for this problem so we'll look into this further. In the mean time, the best solution for this problem is to mount the NFS filesystem with the "readdir" option, which effectively disables READDIRPLUS for that filesystem.

Dave
Dave Olker
HPE Pro

Re: nfs mount problem

Update: this problem has been root-caused to being a defect in the CDFS code. The problem is fixed in the 11.31 patch PHKL_40531:

( QX:QXCR1000940411 )
The following symptoms are seen on a NFS client:
1. ls(1) or ll(1) command hangs on a NFS mount point
exported from a CDFS filesystem.

Unfortunately this doesn't help Rita because her server is running 11.11. I've got a call into the CDFS lab to find out if they have plans to roll this fix back to 11.11 and 11.23. I'll update here when I hear something.

Regards,

Dave