cancel
Showing results for 
Search instead for 
Did you mean: 

not able to login through CDE

R.Suresh
Frequent Advisor

not able to login through CDE

Dear all,

Here I have B1000 workstation,

I am unable to login through CDE login,
It says "login incorrect" for all the users
Even for root.

But I can able to login through command
line.

Please HELP!

Thanks
R.Suresh.
PDLS
5 REPLIES
Rick Garland
Honored Contributor

Re: not able to login through CDE

Start with the /usr/contrib/bin/X11/dr_dt.
Note the WARNINGS and ERROR messages.

Alex Glennie
Honored Contributor

Re: not able to login through CDE

1. Check the following files : /var/dt/Xerrors & $HOME/.dt/statlog & /var/adm/syslog/syslog.log

do you see any additional errors whilst this occurs ? Do you ever see CDE start ?

2. Run CDE diagnostic : dr_dt and clean-up errors & warnings.

3. Describe what happens (what you see) after you add the users password into the CDE login screen .

this could be down to networking , you could try just using /etc/hosts rather than DNS or NIS to determine :

also check netconf and /etc/hosts entries are the same

or it could be down to permissions or tooltalk : without further errors hard to say ....

also worth doing a bdf just in case somethings reaching 100 %.

keeps us posted on what you find from the above.
Alex Glennie
Honored Contributor

Re: not able to login through CDE

also have you "trusted your system whilst CDE 's running if so :

Perform the following steps to resolve your error:

1. /sbin/init.d/dtlogin.rc stop

Note: Ensure that all users are logged out of CDE.

2. /sbin/init.d/dtlogin.rc start

Also have you installed patches recently ?


glovecar
Occasional Advisor

Re: not able to login through CDE

1. Check dtlogin process
# ps -ef | grep dtlogin

2. Dtlogin Process Start
# /sbin/init.d/dtlogin.rc start

3. Network check
- X11Server ports 6000 open (Firewall)

4. Check the follwing Files
- $HOME/.dt/startlog

5. DNS Setting check
- /etc/nsswitch.conf
hosts: files dns
Lasse Knudsen
Esteemed Contributor

Re: not able to login through CDE

Hi,

I have seen this before. Sometimes (do not know when) the /etc/pam.conf gets messed up (or is missing). Try to copy the file from /usr/newconfig/etc/pam.conf
In a world without fences - who needs Gates ?