General
cancel
Showing results for 
Search instead for 
Did you mean: 

openssl installation problem (make) on HP11iV1

Amit Aherao
Occasional Advisor

openssl installation problem (make) on HP11iV1

Hello,

I am facing problems while installing openssl on HP11iV1.

After configuring openssl I tried executing make command but following issue faced. I searched lot many sites even other Forums but could not find the answer about this.. :(

Bit frustrated with this now..


===================================================
bash-2.04# make
making all in crypto...
( echo "#ifndef MK1MF_BUILD"; \
echo ' /* auto-generated by crypto/Makefile for crypto/cversion.c */'; \
echo ' #define CFLAGS "cc -DOPENSSL_THREADS -DDSO_DL -D_REENTRANT +DA2 .0 +DS2.0 +O3 +Optrs_strongly_typed -Ae +ESlit -DB_ENDIAN -DMD32_XARRAY -D_REENT RANT"'; \
echo ' #define PLATFORM "hpux-parisc2-cc"'; \
echo " #define DATE \"`LC_ALL=C LC_TIME=C date`\""; \
echo '#endif' ) >buildinf.h
cc -I. -I.. -I../include -DOPENSSL_THREADS -DDSO_DL -D_REENTRANT +DA2.0 +DS2.0 +O3 +Optrs_strongly_typed -Ae +ESlit -DB_ENDIAN -DMD32_XARRAY -D_REENTRA NT -c cryptlib.c
cc: +DA2.0: No such file or directory
cc: +DS2.0: No such file or directory
cc: +O3: No such file or directory
cc: +Optrs_strongly_typed: No such file or directory
cc: +ESlit: No such file or directory
: error: missing '(' after predicate
*** Error exit code 1

Stop.
*** Error exit code 1

Stop.

===================================================


Snapshot of installed components:

===================================================

gcc 4.2.3 gcc
gettext 0.17 gettext
gsk7bas 7.0.1.9 IBM gsk7 RUNTIME KIT
libgcc 4.2.3 libgcc
libiconv 1.13 libiconv
zlib 1.2.3 zlib
===================================================

I am using 4.2.3 gcc and cc is pointing to where gcc is installed.

Any help in this regards would be helpful. Thanks!

PS: H.Merijn Brand (procura) Could you please help in this?? I found many of the questions been answered by you.. Thanks again.

15 REPLIES
Horia Chirculescu
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

Horia.

Why not using the supported version for your HP-UX11iv1?

A.05.30.007


You can get this depot from:

https://h20392.www2.hp.com/portal/swdepot/displayProductInfo.do?productNumber=T1471AA

Horia.
Best regards from Romania,
Horia.
Horia Chirculescu
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

Sorry.. my mistake, you are talking about openssl...

Here it is the binary depot from the porting page:

http://hpux.connect.org.uk/hppd/hpux/Languages/openssl-0.9.8k/

You must install all build-time dependencies (follow that links and install the depots if not already present on your system)

Horia.
Best regards from Romania,
Horia.
Amit Aherao
Occasional Advisor

Re: openssl installation problem (make) on HP11iV1

Hello Horia,

I am using openssl-0.9.8e to install on Hp11iV1. Just to give more info, I am trying this on 64 bit HP.

--Amit.
Horia Chirculescu
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

>I am using 4.2.3 gcc and cc is pointing to where gcc is installed

What do you mean? That you will use gcc even when calling cc? This is wrong because +O options are recognized by cc compiler only. gcc does not know about this.

Would be better to install a pre-compiled package as I suggested below. Use the last link from porting page.

Horia.
Best regards from Romania,
Horia.
Horia Chirculescu
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

... and unlink cc from gcc

Horia.
Best regards from Romania,
Horia.
Steven Schweda
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

> bash-2.04# make

Isn't there a "configure" step before that?

> I am using 4.2.3 gcc

Ok.

> and cc is pointing to
> where gcc is installed.

Bad idea.

> Would be better [...]

That might be better. Or, stop trying to
"help" people find gcc. And show what you
_really_ did to build this thing.

> I am using openssl-0.9.8e [...]

Why the (very) obsolete version?
Steven Schweda
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

Around here:

dy # uname -a
HP-UX dy B.11.11 U 9000/785 2012616114 unlimited-user license

dy # gcc --version
gcc (GCC) 4.4.2
[...]

dy # gmake --version
GNU Make 3.81
[...]
This program built for hppa2.0w-hp-hpux11.11

Following the instructions (mostly) in
INSTALL for openssl-0.9.8m seems to work
properly:

./config
gmake
gmake test
gmake install

dy # echo version | /usr/local/ssl/bin/openssl
OpenSSL> OpenSSL 0.9.8m 25 Feb 2010
OpenSSL> dy #

Around here, where "cc" is "cc" and "gcc" is
"gcc", the "config" script seemed to have no
trouble at all identifying and using GCC.
Amit Aherao
Occasional Advisor

Re: openssl installation problem (make) on HP11iV1

I have removed the link of cc to gcc.

As per suggestion, I tried installing openssl-0.9.8k-hppa-11.11.depot.

I am getting warnings messages while installing openssl-0.9.8k-hppa-11.11.depot through swinstall:

===============================================

* Summary of Analysis Phase: â â
â â * 4 of 4 filesets had no Errors or Warnings. â
â â * The Analysis Phase succeeded. â â
â â â â
â â â â
â â * Beginning the Install Execution Phase.

* Filesets: 4 â â
â â * Files: 1109 â â
â â * Kbytes: 12382 â â
â â * Installing fileset "openssl.openssl-INC,r=0.9.8k" (1 of 4). â â
â â * Installing fileset "openssl.openssl-MAN,r=0.9.8k" (2 of 4). â â
â â * Installing fileset "openssl.openssl-RUN,r=0.9.8k" (3 of 4). â
â â * Installing fileset "openssl.openssl-SHLIBS,r=0.9.8k" (4 of 4). â â
â â * Running install clean command /usr/lbin/sw/install_clean. â â
â â WARNING: Transition links are not created for the filesets installed â â
â â at the target. After booting up from the system using â â
â â the alternate root at the target, run tlinstall command to
create transition links. â â
â â WARNING: The command "/usr/lbin/sw/install_clean" had warnings. The â â
â â installation will continue. Check the above output for â â
â â details about the warnings. â â
â â * Building the software file â â
â â "/opt/openssl-0.9.8/var/adm/sw/needs_config" to be used for â â
â â post-reboot "swconfig" execution. The information in this â â
â â file will be used as input to "swconfig" after the system â â
â â reboots.
* Summary of Execution Phase: â â
â â * 4 of 4 filesets had no Errors or Warnings. â â
â â WARNING: The Execution Phase had warnings. See the above output for â â
â â details.


===============================================

bash-2.04# swlist | grep opensl
bash-2.04#

=================================================
At target path of openssl:

bash-2.04# cd /opt/openssl-0.9.8
bash-2.04# ls
usr var
bash-2.04#

=================================================
When tried installing openssh-5.3p1-hppa-11.11.depot through swinstall:

tivsec156:/opt/openSSH5.3p1/var/adm/sw/swagent.log â â
â â * Reading source for product information. â â
â â * Reading source for file information. â â
â â The corequisite "openssl.openssl-SHLIBS" for fileset â
â â "openssh.openssh-RUN,r=5.3p1" cannot be successfully resolved. â
â â ERROR: The dependencies for fileset "openssh.openssh-RUN,r=5.3p1" â â
â â cannot be resolved (see previous lines). â â
â â You must resolve the above dependencies before operating on â â
â â this fileset or change the "enforce_dependencies" option to â â
â â "false".


=================================================
Amit Aherao
Occasional Advisor

Re: openssl installation problem (make) on HP11iV1

Thanks Steven, your inputs helped me a lot in resolving above issue. But now I am facing some different problem.

After successfully "./config --prefix=/opt/openssl-0.9.8e/ " I tried to execute "gmake" and after 5 minutes of execution following error observed:

===================================================
[...]
gmake[2]: Entering directory `/amit/openssl-0.9.8e/apps'
( :; LIBDEPS="${LIBDEPS:--L.. -lssl -L.. -lcrypto -Wl,+s -ldld}"; LDCMD="${LDCM D:-gcc}"; LDFLAGS="${LDFLAGS:--DOPENSSL_THREADS -DDSO_DL -D_REENTRANT -march=2. 0 -O3 -DB_ENDIAN -D_REENTRANT}"; LIBPATH=`for x in $LIBDEPS; do if echo $x | gre p '^ *-L' > /dev/null 2>&1; then echo $x | sed -e 's/^ *-L//'; fi; done | uniq`; LIBPATH=`echo $LIBPATH | sed -e 's/ /:/g'`; LD_LIBRARY_PATH=$LIBPATH:$LD_LIBRAR Y_PATH ${LDCMD} ${LDFLAGS} -o ${APPNAME:=openssl} openssl.o verify.o asn1pars.o req.o dgst.o dh.o dhparam.o enc.o passwd.o gendh.o errstr.o ca.o pkcs7.o crl2p7. o crl.o rsa.o rsautl.o dsa.o dsaparam.o ec.o ecparam.o x509.o genrsa.o gendsa.o s_server.o s_client.o speed.o s_time.o apps.o s_cb.o s_socket.o app_rand.o versi on.o sess_id.o ciphers.o nseq.o pkcs12.o pkcs8.o spkac.o smime.o rand.o engine.o ocsp.o prime.o ${LIBDEPS} )

/usr/ccs/bin/ld: (Warning) At least one PA 2.0 object file (openssl.o) was detec ted. The linked output may not run on a PA 1.x system.
/usr/ccs/bin/ld: Unrecognized argument: +init
/usr/ccs/bin/ld: Usage: /usr/ccs/bin/ld [options] [flags] files
collect2: ld returned 1 exit status
gmake[2]: *** [link_app.] Error 1
gmake[2]: Leaving directory `/amit/openssl-0.9.8e/apps'
gmake[1]: *** [openssl] Error 2
gmake[1]: Leaving directory `/amit/openssl-0.9.8e/apps'
gmake: *** [build_apps] Error 1




===================================================

What can be done to resolve this issue? Suggestions are welcome. Thanks!
Steven Schweda
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

> What can be done to resolve this issue?

I don't know. Could be a bug in the
openssl-0.9.8e kit. According to:

http://marc.info/?l=openssl-announce&m=117223949219571&w=2

0.9.8e was released around three years ago.
I wouldn't be amazed if a bug or two got
fixed between then and now.

I looked through the logs of my build of
0.9.8m, and I can see no evidence of a
"+init" anywhere. I doubt that you would
have anything weird in your environment which
might confuse the builders, but, just to be
sure, you might try something like:

env | grep init

> > I am using openssl-0.9.8e [...]
>
> Why the (very) obsolete version?

Still wondering.

If you can get the new one to fail, then we
might learn more. I have no great interest
in trying to debug the three-year-old
(obsolete) one.
Amit Aherao
Occasional Advisor

Re: openssl installation problem (make) on HP11iV1

I tried by downloading openssl-0.9.8m but still observed the same error as previous.

gcc -DMONOLITH -I.. -I../include -DOPENSSL_THREADS -DDSO_DL -D_REENTRANT -march=2.0 -O3 -DB_ENDIAN -D_REENTRANT -c -o openssl.o openssl.c
rm -f openssl
shlib_target=; if [ -n "" ]; then \
shlib_target="hpux-shared"; \
elif [ -n "" ]; then \
FIPSLD_CC="gcc"; CC=../fips/fipsld; export CC FIPSLD_CC; \
fi; \
LIBRARIES="-L.. -lssl -L.. -lcrypto" ; \
[ "x" = "xlibfips" ] && LIBRARIES="$LIBRARIES -lfips"; \
gmake -f ../Makefile.shared -e \
CC="${CC}" APPNAME=openssl OBJECTS="openssl.o verify.o asn1pars.o req.o dgst.o dh.o dhparam.o enc.o passwd.o gendh.o errstr.o ca.o pkcs7.o crl2p7.o crl.o rsa.o rsautl.o dsa.o dsaparam.o ec.o ecparam.o x509.o genrsa.o gendsa.o s_server.o s_client.o speed.o s_time.o apps.o s_cb.o s_socket.o app_rand.o version.o sess_id.o ciphers.o nseq.o pkcs12.o pkcs8.o spkac.o smime.o rand.o engine.o ocsp.o prime.o cms.o" \
LIBDEPS=" $LIBRARIES -Wl,+s -ldld" \
link_app.${shlib_target}
gmake[2]: Entering directory `/amit/openssl-0.9.8m/apps'
( :; LIBDEPS="${LIBDEPS:--L.. -lssl -L.. -lcrypto -Wl,+s -ldld}"; LDCMD="${LDCMD:-gcc}"; LDFLAGS="${LDFLAGS:--DOPENSSL_THREADS -DDSO_DL -D_REENTRANT -march=2.0 -O3 -DB_ENDIAN -D_REENTRANT}"; LIBPATH=`for x in $LIBDEPS; do if echo $x | grep '^ *-L' > /dev/null 2>&1; then echo $x | sed -e 's/^ *-L//'; fi; done | uniq`; LIBPATH=`echo $LIBPATH | sed -e 's/ /:/g'`; LD_LIBRARY_PATH=$LIBPATH:$LD_LIBRARY_PATH ${LDCMD} ${LDFLAGS} -o ${APPNAME:=openssl} openssl.o verify.o asn1pars.o req.o dgst.o dh.o dhparam.o enc.o passwd.o gendh.o errstr.o ca.o pkcs7.o crl2p7.o crl.o rsa.o rsautl.o dsa.o dsaparam.o ec.o ecparam.o x509.o genrsa.o gendsa.o s_server.o s_client.o speed.o s_time.o apps.o s_cb.o s_socket.o app_rand.o version.o sess_id.o ciphers.o nseq.o pkcs12.o pkcs8.o spkac.o smime.o rand.o engine.o ocsp.o prime.o cms.o ${LIBDEPS} )
/usr/ccs/bin/ld: (Warning) At least one PA 2.0 object file (openssl.o) was detected. The linked output may not run on a PA 1.x system.
/usr/ccs/bin/ld: Unrecognized argument: +init
/usr/ccs/bin/ld: Usage: /usr/ccs/bin/ld [options] [flags] files
collect2: ld returned 1 exit status
gmake[2]: *** [link_app.] Error 1
gmake[2]: Leaving directory `/amit/openssl-0.9.8m/apps'
gmake[1]: *** [openssl] Error 2
gmake[1]: Leaving directory `/amit/openssl-0.9.8m/apps'
gmake: *** [build_apps] Error 1
Horia Chirculescu
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

Amit,

The software from the porting archive is installed relatively to /usr/local. This means that the libraries are installed in /usr/local/lib. This path must be added to the default search path.

This means that you must do some additional steps in order to let other binaries find the run time libraries.

If this seems to be too complicated, you can install the binary depot from HP site:

https://h20392.www2.hp.com/portal/swdepot/displayInstallInfo.do?productNumber=OPENSSL11I

This would upgrade your existing /opt/openssl directory.

First remove the previous installation (using swremove) in order to save space.

Horia.
Best regards from Romania,
Horia.
Horia Chirculescu
Honored Contributor

Re: openssl installation problem (make) on HP11iV1

>default search path

... for shared libraries of course.

Read:

http://docs.hp.com/en/B2355-90655/ch05.html

The corequisite "openssl.openssl-SHLIBS" for fileset â Â
â  â  "openssh.openssh-RUN,r=5.3p1" cannot be successfully

If you need also openssh, the depot that I sent to you on my first message contain also the openssl. (quote from that HP document)

"HP-UX Secure Shell version A.05.30 contains the following libraries:

* zlib v1.2.3
* OpenSSL v 0.9.8l (OpenSSL is a shared library on HP-UX 11i v3)
* TCP Wrappers v7.6-ipv6.4
"

Do not install this from a ssh session because the ssh daemon must be restarted (in fact stop the old version and then start the newly installed version) in order to complete installation.

Horia.
Best regards from Romania,
Horia.
Amit Aherao
Occasional Advisor

Re: openssl installation problem (make) on HP11iV1

Hello,

Thanks much for your valuable replies my problems got solved by installing respective depots as Horia suggested..

Thanks for your time.
Dennis Handly
Acclaimed Contributor

Re: openssl installation problem (make) on HP11iV1

>ld: Unrecognized argument: +init

You need a more recent linker patch to support gcc's requirement for +init.
The recommended patch is PHSS_39749.