Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

oracle 10.2 installtion on 11.31

Rahul Tiwari
Advisor

oracle 10.2 installtion on 11.31

Dear Gurus,
i am installing oracle 10.2 on 11.31.As ./runInstaller was giving error
stating the the OS version should be 11.23 and not 11.31 , i was asked to
proceed with ./runInstaller -ignoreSysPreReqs.consequently ,the error was .
....Checking operating system requirements ...
Expected result: One of 11.23
Actual Result: 11.31
Check complete. The overall result of this check is: Failed <<<<
Problem: Oracle Database 10g is not certified on the current operating system.
Recommendation: Make sure you are installing the software on the correct platform.

after the core binary where installed , i unzipped the patch set
p6810189_10204_HPUX-IA64.zip.
1) How can i verify the installation was OK ?
2) Hereis the error that i am getting when starting sqlplus
$ ./sqlplus
Error 6 initializing SQL*Plus
Message file sp1.msb not found
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory
$ whoami
oracle2
$ cd
$ more .profile | grep -i oracle
ORACLE_BASE=/oracle
ORACLE_HOME=/oraclehome/OraHome_1
PATH=$PATH:.:$ORACLE_HOME/bin:/usr/bin
3)i am not abel to start odbc from the oracle.
i am expecting after exporting the diaplay , i whould be able to
see he oracle databse configutaion assistance (odbc).

9 REPLIES
Avinash20
Honored Contributor

Re: oracle 10.2 installtion on 11.31

Hi,

this is a bug with the Oracle script which need to be modified

1) How can i verify the installation was OK ?

If the 10.2 support 11.31, then your installation might be sucessful

2) Hereis the error that i am getting when starting sqlplus
$ ./sqlplus
SP2-0750: You may need to set ORACLE_HOME to your Oracle software directory

## Check if you have set the variable ORACLE_HOME to where the oracle was installed

# echo $ORACLE_HOME

## You could install any X-emulator software like X-manager, Reflection-X and then start your installation
"Light travels faster than sound. That's why some people appear bright until you hear them speak."
Rahul Tiwari
Advisor

Re: oracle 10.2 installtion on 11.31

Dear Avinash ,

Thanks for the reply!
Please tell a solution which will establish "is successfull"(i would have created
a test DB has the odbc GUI would have come up)
I have set the oracle home correctly in profile.
I alredy have xmanger as an x term window and exporting the display too.
Duncan Edmonstone
Honored Contributor

Re: oracle 10.2 installtion on 11.31

ARe you sure you have your ORACLE_HOME set *correctly* what do you see from:

ll $ORACLE_HOME




HTH

Duncan

HTH

Duncan
Rahul Tiwari
Advisor

Re: oracle 10.2 installtion on 11.31

Hello Duncan ,

here's the o/p :
$ ll $ORACLE_HOME
total 128
drwxr-x--- 5 oracle2 dba 1024 Feb 5 14:52 OPatch
drwxr-x--- 7 oracle2 dba 96 Feb 5 13:44 assistants
drwxr-xr-x 2 oracle2 dba 8192 Feb 5 15:04 bin
drwxr-x--- 7 oracle2 dba 1024 Feb 5 14:52 ccr
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:46 cdata
drwxr-x--- 4 oracle2 dba 1024 Feb 5 14:58 cfgtoollogs
drwxr-x--- 4 oracle2 dba 96 Feb 5 13:44 clone
drwxr-x--- 2 oracle2 dba 96 Feb 5 13:46 config
drwxr-x--- 6 oracle2 dba 96 Feb 5 13:44 crs
drwxr-x--- 7 oracle2 dba 96 Feb 5 13:46 css
drwxr-x--- 10 oracle2 dba 1024 Feb 5 13:46 ctx
drwxr-x--- 2 oracle2 dba 96 Feb 5 13:44 dbs
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 demo
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 diagnostics
drwxr-x--- 5 oracle2 dba 96 Feb 5 13:44 has
drwxr-x--- 7 oracle2 dba 96 Feb 5 13:50 hs
drwxr-x--- 5 oracle2 dba 1024 Feb 5 14:58 install
-rw-r----- 1 oracle2 dba 38 Feb 5 14:51 install.platform
drwxr-x--- 14 oracle2 dba 1024 Feb 5 14:58 inventory
drwxr-x--- 7 oracle2 dba 96 Feb 5 13:44 javavm
drwxr-x--- 4 oracle2 dba 96 Feb 5 13:46 jdbc
drwxr-x--- 11 oracle2 dba 1024 Feb 5 13:46 jdk
drwxr-x--- 2 oracle2 dba 2048 Feb 5 14:52 jlib
drwxr-x--- 3 oracle2 dba 96 Feb 5 14:52 jre
drwxr-x--- 13 oracle2 dba 1024 Feb 5 13:46 ldap
drwxr-x--- 4 oracle2 dba 6144 Feb 5 14:58 lib
drwxr-x--- 2 oracle2 dba 4096 Feb 5 14:58 lib32
drwxr-x--- 6 oracle2 dba 96 Feb 5 13:44 md
drwxr-x--- 2 oracle2 dba 96 Feb 5 13:44 mesg
drwxr-x--- 7 oracle2 dba 96 Feb 5 13:46 mgw
drwxr-x--- 13 oracle2 dba 1024 Feb 5 13:50 network
drwxr-x--- 6 oracle2 dba 96 Feb 5 13:44 nls
drwxr-x--- 15 oracle2 dba 1024 Feb 5 13:50 oc4j
drwxr-x--- 5 oracle2 dba 96 Feb 5 13:44 olap
drwxr-x--- 7 oracle2 dba 96 Feb 5 13:46 opmn
-rw-r--r-- 1 oracle2 dba 56 Feb 5 13:53 oraInst.loc
drwxr-x--- 4 oracle2 dba 96 Feb 5 13:44 oracore
drwxr-x--- 8 oracle2 dba 1024 Feb 5 13:44 ord
drwxr-x--- 7 oracle2 dba 1024 Feb 5 14:52 oui
drwxr-x--- 4 oracle2 dba 96 Feb 5 13:44 owm
drwxr-x--- 6 oracle2 dba 96 Feb 5 13:44 perl
drwxr-x--- 7 oracle2 dba 1024 Feb 5 13:44 plsql
drwxr-x--- 8 oracle2 dba 1024 Feb 5 13:44 precomp
drwxr-x--- 7 oracle2 dba 96 Feb 5 13:46 racg
drwxr-x--- 15 oracle2 dba 1024 Feb 5 14:53 rdbms
drwxr-x--- 4 oracle2 dba 1024 Feb 5 13:46 relnotes
-rwxr-xr-x 1 oracle2 dba 11406 Feb 5 14:58 root.sh
-rwxr-xr-x 1 oracle2 dba 0 Jun 7 2005 root.sh.old
-rwxr-xr-x 1 oracle2 dba 9444 Feb 5 13:50 root.sh.old.1
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 slax
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 sqlj
drwxr-x--- 9 oracle2 dba 1024 Feb 5 13:46 sqlplus
drwxr-x--- 13 oracle2 dba 1024 Feb 5 13:46 srvm
drwxr-x--- 14 oracle2 dba 1024 Feb 5 14:52 sysman
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 tg4ifmx
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 tg4ingr
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 tg4sybs
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 tg4tera
drwxr-x--- 4 oracle2 dba 96 Feb 5 13:44 uix
drwxr-x--- 3 oracle2 dba 96 Feb 5 13:44 wwg
drwxr-x--- 6 oracle2 dba 1024 Feb 5 13:45 xdk
Steven E. Protter
Exalted Contributor

Re: oracle 10.2 installtion on 11.31

Shalom,

This message is straightforward.

Check complete. The overall result of this check is: Failed <<<<
Problem: Oracle Database 10g is not certified on the current operating system.
Recommendation: Make sure you are installing the software on the correct platform.


If its not a certified OS, you can't do it.

Though it may be an Oracle bug because I believe that version of the database IS supported on 11.31.

Check http://metalink.oracle.com for more information

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Rahul Tiwari
Advisor

Re: oracle 10.2 installtion on 11.31

i will come towmarrow and do a fresh installation(restore from ignite, recreate FS, and then oracle binary and database...thanks god it's not production).Thanks Avinash and Duncan
Court Campbell
Honored Contributor

Re: oracle 10.2 installtion on 11.31

It's supported but the installer has not been updated AFAIK. Issues like this are not new for the installer on HP-UX. Heck, I think it still looks for obsolete kernel tunables.
"The difference between me and you? I will read the man page." and "Respect the hat." and "You could just do a search on ITRC, you don't need to start a thread on a topic that's been answered 100 times already." Oh, and "What. no points???"
Emil Velez
Honored Contributor

Re: oracle 10.2 installtion on 11.31

I installed oracle on a 10.20 system and then created a tarball of the /opt/oracle directory and restored it to a 11.31 system after creating oratab and dba group and oracle users worked fine.
Tonny Sejr Kromann
Frequent Advisor

Re: oracle 10.2 installtion on 11.31

To install, you can also change the file oraparam.ini.
There is a line under "[Certified Versions]" stating: "HPUX=B.11.23", change it to "HPUX=B.11.23,B.11.31"
Below is another section on 11.23 "[HPUX-B.11.23-required]" that you have to copy and modify for 11.31.
Then the installer will run.
In the installer you then have to confirm that you checked the patches and kernel parameters.

--
Best regards
Tonny