cancel
Showing results for 
Search instead for 
Did you mean: 

performance problem

SOLVED
Go to solution
Fransisco Aris
Frequent Advisor

performance problem

hi guys, i had some serious performance problem on my server. the information is swap file are just 15% utilized but the idle is 0% so this impact when user access it. please give me some clue you are miracle guys here, what general problem are I'm facing now and what tools I'm supposed to use to figure out the problem. many thanks..

cheers,
7 REPLIES
Alzhy
Honored Contributor

Re: performance problem

First, give us the top CPU processes of thine system (top or glance).

It will at least give us an idea of what "uses" your system so heavily -- which is really what your issue is.

Is this the first time thi has happened? Is this a huge deviation from its normal performance?

Hakuna Matata.
Fransisco Aris
Frequent Advisor

Re: performance problem

hi Alzhy, at the moment the hint this system are using for JDE. but for top output and etc I will give update next hours because now in my country are still midnight.
Fransisco Aris
Frequent Advisor

Re: performance problem

hi...
here the output do you need. so, it is frontend of JDE application, act as Web Server. Is it normal with swap file are low utilize compare to high cpu utilization??cause when it reach 0% idle user get slow performance. please help for advice.
thanks..
Alzhy
Honored Contributor
Solution

Re: performance problem

Your issue is rather simple. I do not see any problems at all (on thes surface) with your applications. Your rx2660 likley seems to lack ample CPU resources.

The rx2660 I am seeing n what you posted is a sports a single dual core Montecito. Short of having to request another CPU, can you check if HT (HyperThreading) is on please?

Do so by invoking:

root# setboot

If it says HT is enabled -- then enable it in the kernel by setting lcpu_attr to 1 if it happens to be set to 0 (disabled).

Of course, now knowing your Java code/app -- and if it is supposed to be that demanding or performing - I cannot say 100% sure if your lone 1 CPU - dual core, 4vCPU (via Hyperthreading) will be enough or is enough.. But try to do as I suggest first by checking and enabling HT.. HT can yield performance boosts of anywhere between 10 to 30 percent (dpeending onthe app) in my experience with these Montecitos.
Hakuna Matata.
Fransisco Aris
Frequent Advisor

Re: performance problem

superb Alzhy!! i can't wait to try this solution :) and ASAP i will update how is it going. another question, how / when swap device (/dev/vg00/lvol2) are using by system?because by the time (also when cpu reach peak) this swap device are not utilized by system, you can see there 0% used by swapinfo command.
Ismail Azad
Esteemed Contributor

Re: performance problem

Hi Francisco,

Note :- "Applications that are not 'hyperthreading aware' which have HT enabled can yield huge performance problems", which is why you have the attribute that can be set for this reason. However, the Pharoah knows the application supports HT.

> /dev/vg00/lvol2

This is the lvol for your primary swap. It is always used and is the minimum amount of swap that is required for your system to boot. If you do a glance at any point of time even if you don't cross the "minfree" or "lotsfree" threshold, you will still see some amount of swap being used which is your primary swap.

Regards
Ismail Azad
Read, read and read... Then read again until you read "between the lines".....
Fransisco Aris
Frequent Advisor

Re: performance problem

nice info ismail, clearly why HT are must be enabled for certain application.

for swap space /dev/vg00/lvol2, i don't see there is used by application. i do "swapinfo -tam" second by second there is still 0% but for physical memory there is always different value (used by application).