Showing results for 
Search instead for 
Did you mean: 

pfs_mount error

Youlette Etienne_2
Regular Advisor

pfs_mount error


I am trying to mount an Oracle cdrom using the pfs_mount command. I get the following error:

# /usr/sbin/pfs_mount /CDROM
/usr/sbin/pfs_mount: /dev/dsk/c2t2d0 on /CDROM: not rrip.
/usr/sbin/pfs_mount: giving up on /CDROM

I followed the "nohup" instructions to start the pfs daemons and created the /etc/pfs_fstab file.

# cat /etc/pfs_fstab

The following daemons are running:
# ps -fea|grep pfs
root 4906 26288 0 11:52:19 pts/t5 0:00 /usr/sbin/pfs_mountd
root 14654 14650 0 11:54:58 pts/t5 0:00 pfsd.rpc
root 14650 26288 0 11:54:58 pts/t5 0:00 /usr/sbin/pfsd
root 4909 4906 0 11:52:19 pts/t5 0:00 pfs_mountd.rpc
root 28478 9284 0 12:23:55 pts/t7 0:00 grep pfs

Please help.

If at first you don't succeed, change the rules!
John Palmer
Honored Contributor

Re: pfs_mount error

Hi Youlette,

Your post suggests that /etc/pfs_fstab is empty. It should contain the line:-

/dev/dsk/c2t2d0 /cdrom pfs-rrip xlat=unix 0 0
If you cd drive is c2t2d0.

Do a mkdir /cdrom then pfs_mount /cdrom should work ok with an Oracle install CD.

Rick Garland
Honored Contributor

Re: pfs_mount error

You will need the /etc/pfs_fstab file with the rrip option or you can pfs_mount from the command line by specifing the format, in this case, the rrip.
Ken Scharpell
Valued Contributor

Re: pfs_mount error

Your /etc/pfs_fstab file should look like this for optimal settings (reliability)

/dev/rdsk/cxxxxxx /SD_CDROM (or /cdrom) pfs-rrip xlat=unix,soft 1 0

Dont forget to use the /dev/rdsk - much more reliable than /dev/dsk, and the soft option, this way if it hangs you can remove the /etc/pfs_mnttab file and it wont hang the server forcing an immediate reboot - although you will still need to reboot later to free up the cd drive.
The whole world is a simple perl script
Youlette Etienne_2
Regular Advisor

Re: pfs_mount error

sorry, didn't notice that the /etc/fstab did not post properly.

Originally I had
# cat /etc/pfs_fstab
/dev/dsk/c0t2d0 /SD_CDROM pfs-rrip xlat=unix 0 0

which produced the above error.

I changed it to /dev/rdsk/c0t2d0 /SD_CDROM pfs-rrip xlat=unix,soft 1 0

and killed and restarted the pfs daemons.
I got the same error.

/usr/sbin/pfs_mount: /dev/rdsk/c0t2d0 on /SD_CDROM: not rrip.
/usr/sbin/pfs_mount: giving up on /SD_CDROM
If at first you don't succeed, change the rules!
Alan Riggs
Honored Contributor

Re: pfs_mount error

I notice tha tthe path has changed between your first post and your latest. Is the CD on path c0 or c2? Make sure you have the correct one specified in /etc/pfs_fstab. I use the bloack device (/dev/dsk) in my pfs_fstab, and it functions properly.

If your file is correct, try killing all pfs demons and starting them up again. Of course, make sure that nfs is running before starting pfs.
Honored Contributor

Re: pfs_mount error

I agree with Alan here is what I have for a c2t2do:
/dev/dsk/c2t2d0 /SD_CDROM pfs-rrip xlat=unix 1 0
Now are you sure the cd you are wanting to mount is rockridge format?
have you tried simply:
mount -o cdcase /dev/dsk/c2t2d0 /SD_CDROM
Faizer Jameel
Frequent Advisor

Re: pfs_mount error

Step 1 : Login as root

Step 2 : Ensure the /etc/pfs_fstab file contains the following entry
/dev/dsk/cxtxdx /cdrom pfs-rrip xlat=unix 0 0

x = this is machine dependent in your case c1t2d0

Step 3 :Ensure the CDROM is loaded

Step 4 :enter the following commands
# Nohup /usr/sbin/pfs_mountd &
# nohup /usr/sbin/pfsd &

Step 5 :mount the cd
# pfs_mount
?o xlat=unix /dev/rdsk/cxtxdx /cdrom