Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

postfix missing 250-VRFY

SOLVED
Go to solution
'chris'
Super Advisor

postfix missing 250-VRFY

hi

I'm using postfix version 2.3.8 installed on debian etch stable, but if I try:

# telnet localhost 25

and

ehlo localhost

then I get the following:

250-ext.undostres.ch
250-PIPELINING
250-SIZE 10240000
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250-ENHANCEDSTATUSCODES
250-8BITMIME
250 DSN



250-VRFY is missing in my case !



# cat /etc/postfix/main.cf

program_directory = /usr/lib/postfix
command_directory = /usr/sbin
daemon_directory = /usr/lib/postfix
soft_bounce = yes

#header_checks = regexp:/etc/postfix/header_checks

#smtpd_banner = $myhostname ESMTP $mail_name (Debian/GNU)
biff = no

# appending .domain is the MUA's job.
append_dot_mydomain = no

# Uncomment the next line to generate "delayed mail" warnings
#delay_warning_time = 4h

smtpd_helo_required = yes
disable_vrfy_command = yes
strict_rfc821_envelopes = yes

myhostname = ext.mydomain.net
mydomain = mydomain.net
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
myorigin = /etc/mailname
mydestination = localhost, $myhostname, $mydomain, localhost.$mydomain, localhost.$myhostname
virtual_maps = hash:/etc/postfix/virtusertable

smtpd_banner = $myhostname ESMTP Mailserver

smtpd_helo_restrictions = reject_invalid_hostname
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, reject_unauth_destination
smtpd_sender_restrictions = reject_unknown_address
smtpd_client_restrictions = reject_invalid_hostname, reject_rbl_client relays.ordb.org

home_mailbox = Maildir/
#local_recipient_maps = proxy:unix:passwd.byname $alias_maps
#local_transport = local

# TLS
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_enforce_tls = no
smtpd_tls_auth_only = no

# SASL (Simple Authentication and Security Layer)
smtpd_sasl_auth_enable = yes
smtpd_sasl2_auth_enable = yes
smtpd_sasl_security_options = noanonymous
smtpd_sasl_local_domain = $myhostname
broken_sasl_auth_clients = yes

mailbox_command =
recipient_delimiter = +

mynetworks = 127.0.0.0/8 202.X.X.0/28 192.168.115.0/24

# virtual email accounts
virtual_alias_domains =
virtual_alias_maps = mysql:/etc/postfix/mysql-virtual_forwardings.cf, mysql:/etc/postfix/mysql-virtual_email2email.cf
virtual_mailbox_domains = mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_mailbox_base = /var/vmail
virtual_uid_maps = static:5000
virtual_gid_maps = static:5000
transport_maps = mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_create_maildirsize = yes
virtual_mailbox_extended = yes
virtual_mailbox_limit_maps = mysql:/etc/postfix/mysql-virtual_mailbox_limit_maps.cf
virtual_mailbox_limit_override = yes
virtual_maildir_limit_message = "The user you are trying to reach is over quota."
virtual_overquota_bounce = yes
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps

relayhost =
#mailbox_size_limit = 51200000
mailbox_size_limit = 20240000
message_size_limit = 10240000
strict_rfc821_envelopes = yes
inet_interfaces = all

content_filter = amavis:[127.0.0.1]:10024
receive_override_options = no_address_mappings



what's wrong and howto solve this problem ?

kind regards
chris
5 REPLIES
Ivan Ferreira
Honored Contributor
Solution

Re: postfix missing 250-VRFY

Change:

disable_vrfy_command = yes

To

disable_vrfy_command = no

And reload postfix.
Por que hacerlo dificil si es posible hacerlo facil? - Why do it the hard way, when you can do it the easy way?
Matti_Kurkela
Honored Contributor

Re: postfix missing 250-VRFY

One of the main problems of VRFY in these days is that spammers can and will use it to iterate through all possible short usernames (certainly at least up to 6 characters, maybe even longer) to find recipients for junk email.

This is why VRFY is usually disabled by default in modern email system installations.

MK

MK
'chris'
Super Advisor

Re: postfix missing 250-VRFY

thanks,
I'll leave this option disabled.

I have other question:
is it my configuration correct
or there are some other options I can disable or enable ?

Steven E. Protter
Exalted Contributor

Re: postfix missing 250-VRFY

Shalom,

You should only listen for mail on localhost if you don't need inbound mail.

http://www.howtoforge.com/virtual_postfix_antispam

http://www.postfix.org/spam.html

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
'chris'
Super Advisor

Re: postfix missing 250-VRFY

thanks, but I need inbound mails.

this is an internt mail server for some virtual domains.