Simpler Navigation for Servers and Operating Systems
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
cancel
Showing results for 
Search instead for 
Did you mean: 

problem sending mail

Burhan Koni
Advisor

problem sending mail

Hi I have HP9000 (HP-UX 11i),I configured the /etc/hosts , for the smtp server, also I added the smtp entry to /etc/mail/sendmail.cf
but no message can reach. the following is the output of sendmail:
# sendmail -v burhan.koni@paltel.net
paltel.net: Name server timeout
burhan.koni@paltel.net... Transient parse error -- message queued for future del
ivery
jkfhvdjk;h;
.
burhan.koni@paltel.net... queued
#


your help is highly appreciated
Regards
Burhan
7 REPLIES
Bruno Ganino
Honored Contributor

Re: problem sending mail

Burhan, sound like setting timeout too little. Try to increase value of timeout.
Bye
Bruno
Torino (Turin) +2H
Bruno Ganino
Honored Contributor

Re: problem sending mail

.....
check also the queue, the spool must be abled.
The queue is /var/spool/mqueue/*
Regards
Bruno
Torino (Turin) +2H
Sanjay_6
Honored Contributor

Re: problem sending mail

Hi Burhan,

Sendmail defaults to a DNS environment unless you are using the service.switch file. If you are using sendmail in a non-DNS env, try this link below.

http://www1.itrc.hp.com/service/cki/docDisplay.do?docLocale=en_US&docId=200000062944294

Hope this helps.

Regds
Berlene Herren
Honored Contributor

Re: problem sending mail

Burhan, a transient parse error is usually associated with your nameserver switch. If you are not using DNS, make sure you have copied /etc/nsswitch.files to /etc/nsswitch.conf and that you do not have a /etc/resolv.conf file.

Berlene
http://www.mindspring.com/~bkherren/dobes/index.htm
Geoff Wild
Honored Contributor

Re: problem sending mail

On top of checking your resolver settings, nsswitch, etc, also check your default gateway and make sure you can traceroute to the host you want to sendmail to.

I'm assuming you have set:

# "Smart" relay host (may be null)
DSyoursmtpserver

in sendmail.cf and restarted sendmail...

Rgds..Geoff

Proverbs 3:5,6 Trust in the Lord with all your heart and lean not on your own understanding; in all your ways acknowledge him, and he will make all your paths straight.
John Stiles
Frequent Advisor

Re: problem sending mail

Burhan,
I assume you have also set up internet connection.
The following items need set to have internet connection and email over the internet:
1) set your default gateway. (the ip address that gets out to the net). check it with:
netstat -rn command.
should have a line in it like:
default xxx UG
note: xxx is the ip address of your gateway.

vi /etc/resolv.conf
add:
domain yourdomain
nameserver external ip address (isp provides)

ls /etc/nsswitch.conf (if it exists)
vi /etc/nsswitch.conf
hosts: dns [notfound=continue tryagain=continue unavail=continue] files

if /etc/etc/nsswitch.conf does not exist,
cp -p /etc/nsswitch.hp_defaults /etc/nsswitch.conf

Now you should be able to get out:
nslookup yahoo.com

you should get a yahoo ip address.

Now set up sendmail.
find your version: type the folowing:
what /usr/sbin/sendmail (mine version is 8.9.3.1 and it works.

Next:
cd /etc/mail
vi sendmail.cw
add the following to the end:
localhost
yourhostname
yourhostname.yourdomainname

Note: yourhostname and yourdomainname are what you have set for your system.

Next:
vi sendmail.cf
#change the following:
Dj$w.yourdomainname
DSyoursmtpserver
O DontBlameSendmail=GroupWritableDirPathSafe
CE root
DMyourdomainname


Now kill sendmail and restart it:
killsm
/sbin/init.d/sendmail start

try the sendmail -v email address command you used. it should work now.

Some of these steps were already givin by others. Sorry about the overlap. These steps are taken right from my notes when I set up internet and email on HP-UX 11i

Good Luck, hope this helps.
John



all things must pass
Burhan Koni
Advisor

Re: problem sending mail

Thank u all guys,
I configured all network parameters again (gateway, DNS, IP).
the problem solved.

Regards