General
cancel
Showing results for 
Search instead for 
Did you mean: 

problem with a DL560 4 CPU installed and and compiling with "make -j8"

Roger Pena
Occasional Advisor

problem with a DL560 4 CPU installed and and compiling with "make -j8"

hi

i wondering if someone can help me to solve or understand why this happen:

http://forums1.itrc.hp.com/service/forums/questionanswer.do?admit=716493758+1107443698128+28353475&threadId=804774

i posted first in the Server forum because i though it was a hardware problem but maybe is a software problem ...
i have none experience with HP forum so i don't know if the same peoples look into diferents forums :-(, sorry if i make it in the wrong way
9 REPLIES
Steven E. Protter
Exalted Contributor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

There is still a problem with both posts.

They do not state the operating system.

They do not state the compiler.

They don't state what the goal of the compile is.

We need more information to help you.

Please post.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Roger Pena
Occasional Advisor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

thanks you for your quick respond,

i will try to anwser the questions you ask:

1- I use CentOS-3.4, it is a clone of RHEL3 U4, and also i test CentOS-4 Beta, the clone of RHEL-4 Beta

2- I use the default compiler: gcc

3- I try to compile courier-imap, courier-libauth, and the kernel

i compiled ok small programs, but not larges one

in case i didn't mention in the other thread, i can compile with "make -j3" (having 4 CPU installed)
if I uninstall one CPU (having 3 CPU installed) I can compile with "make -jN" and N=2,3,4,5,6
Roger Pena
Occasional Advisor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

others things i did:

1- I change the CPU, by a new one and I exchange CPUs with the other box

2- update the ROM to the last one: 9-15-2004

other information:

1- the box has 6 GB of RAM installed
2- two power source, one connected to the UPS and the other to the external power line
3- both box has installed an smart array card ( 532 ) to access an Modular Smart Array 500
dirk dierickx
Honored Contributor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

what about posting the gcc error? or does the machine just hangs after compiling for a while?
Roger Pena
Occasional Advisor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

:-)

no, i dont know if gcc show an error because the box just "power off".
imagine you are compiling and somebody unplug the power cord from the box, what will happen? ok, the same happen to me but with the diference that i also got a "power" front LED in red, when i read the user manual it say that this color in that LED mean "power fail"

i am trying to install another distribution, with diferent flavor to redhat one, but i'm failing because the scsi cciss module, not all "user" distributions has it, but i will find one :-)
Craig Gilmore
Trusted Contributor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

Hi Roger,

This problem sounds like an oops or a crash type scenario... Perhaps a bad module for the power management?

Have you tried the real RedHat 4 Beta? (it is free from RedHat site.) It seems that you have tried different CPU's with the same result. I'd want to check the OS, just in case something was missed in the compile of the clone.

CG
Roger Pena
Occasional Advisor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

yes, i try CentOS4 beta, same result

also I run knoppix-3.6 and make a chroot to the the root fs of the CentOS-4, and the same problem happen, so is not something that redhat add to the kernel

but it could be something with glic or gcc or other non kernel soft, that is why i want to test other complete different distro than redhat flavor

and i change the CPU and the PPM, and nothing change. i use new parts and nothing change, I use other CPU+PPM from other box and the same problem.
i repeate also that the problem happen with my _both_ box, each of them has _two_ power source, is really hard to beleave that some harware part of the box is damage, but ofcourse i know muphy ;-)
Vitaly Karasik_1
Honored Contributor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

I think this is hardware problem.
Replacing CPU isn't enough, you should replace motherboard.

Probably you will be able to detect probkematic CPU with SmartStart CD or with cpuburn http://pages.sbcglobal.net/redelm/
Roger Pena
Occasional Advisor

Re: problem with a DL560 4 CPU installed and and compiling with "make -j8"

this was what a friend of my tall me ...

but is strange for me that both motherboard are faulty ...
i thoungh it coult be a ROM problem that it would never be see it before.
I post it here mainly because two reason.
one: I could be wrong and it is a soft problem or minor hard problem so somebody could help me solve it.
two: it is not so common, at least it looks like to me, to have a DL560 with 4 CPUs and linux out there and here i think i have the chance that HP fellows coult take a "test hardware" and try to reproduce what i'm seeming
i could make any test that dont brake the hardware :-) until my boss presure me to put in production the server :-), off course, i have a point when i say that 4 CPU installed could make the server stop any time the load get high and lose 1 CPU is somethig "sad" so we are waiting until i get a clear idea of what it is happening or lose all the hope.