Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

problems with automount

SOLVED
Go to solution
Tarek
Super Advisor

problems with automount

I have installed the patch in the attached file and from that automount stopped working. Using NIS. Before the installation automount works perfectly. Now when a user enters to this ws he has the following message:
Unable to change to home your directory....
It is not also possible to mount a remote area of another ws. If i user ypwhich command the client points to a slave, and with ypwhich -m all services points to nis master server.
The /etc/automount is configured. I don't know what to do... I wonder if there is a patch that resolves this problem or one that must be installed after the patch i previously installed. OS hpux 10.20, workstation Visualize C3000.
Thanks Tarek
9 REPLIES
Tarek
Super Advisor

Re: problems with automount

sorry the /etc/auto_master
Dan Hetzel
Honored Contributor

Re: problems with automount

Hi Tarek,

I think you should install the latest s700_800 10.20 NFS/NIS cumulative megapatch (PHNE_22288) as it solves quite a few automount issues.

ftp://ftp.itrc.hp.com/hp-ux_patches/s700_800/10.X/PHNE_22288

Best regards,

Dan
Everybody knows at least one thing worth sharing -- mailto:dan.hetzel@wildcroft.com
Frederic Soriano
Honored Contributor

Re: problems with automount

Hello Tarek,

Have a look at /etc/auto_master file. Supposing that your master map is called auto.master, then /etc/auto-master should contain the line:
+auto.master

If using autofs, you can force the re-reading of the map by entering:
automount -f /etc/auto_master -v

You should see the output "/home remounted".

If it does not solve the problem, then try to install the patch as advised by Dan.

Best regards.

Fred.
Tarek
Super Advisor

Re: problems with automount

My /etc/auto_master is:
/net -hosts -hard -timeo=14 -retry=3 -rsize=4096 -wsize=4096
where should i put the +auto_master
Frederic Soriano
Honored Contributor

Re: problems with automount

Tarek,

It does not matter. The thing is one entry per line.
So your /etc/auto_master would eg. look like:

+auto.master
/net ...

Bests,

Fred.
Tarek
Super Advisor

Re: problems with automount

The auto_master is read on each local ws, it doesn't read the nis server's one.
I have modified the nsswitch.conf and put automount=files[NOTFOUND=continue] nis but without success. Then i modified the auto_master and in it is only written:
/net -hosts -hard .In this way it works slowly and not always, but i don't have error message unkown user, i don't know why. When i enter as a user of that ws, su - user, his home directory is mounted by net. This is wrong, it might be read locally. (on all other ws works in this way). I think the problems is concerning auto_master and nsswitch.conf.
If i see what process is running when i start nfs.client (ps -ef | grep automount) on all ws the process is:
/usr/lib/netsvc/fs/automount/automount -f /etc/auto_master, but on that ws the process is:
/usr/sbin/automountd.
Why this difference? I hope i've been clear.
Tarek
Super Advisor

Re: problems with automount

Sorry all for not explaining good, maybe i've been confusing. We use nis in our company, but not for automount. The /etc/auto_master is read on each workstation.
I've solved the problem. It was the /etc/rc.config.d/nfsconf in which there was a parameter AUTOFS=1 that might be 0. I checked it with the other workstations, that was the cause of the different automount process. However thanks all and sorry again for confusion.
Thomas Kollig
Trusted Contributor
Solution

Re: problems with automount

There are two versions of automount:
/usr/lib/netsvc/fs/autofs/automount (new)
/usr/lib/netsvc/fs/automount/automount).

The new one starts /usr/sbin/automountd. So I think you use both versions on different workstations. Look in the /etc/rc.config.d/nfsconf file: AUTOFS=1 for the new and AUTOFS=0 for the old one.

Thomas
Frederic Soriano
Honored Contributor

Re: problems with automount

Tarek,

Happy that you were able to solve your problem :o)

I think you should go and have a look at the following doc:
http://docs.hp.com/hpux/onlinedocs/B1031-90045/B1031-90045.html

In chapter Configuring and Administering NFS, you have two relevant parts that may help you making distinction between both NFS automounters:

* Configuring and Administering the NFS Automounter
* Configuring and Administering AutoFS

I know there was a doc explaining pros and cons between both automounters, but I can't remind where it was.

I hope this helps !

Bests,

Fred.