Re: problems with ucd-snmp

Sang Yi
Occasional Contributor

problems with ucd-snmp

i'm having some issues with the ucd-snmp-4.2.5-7cmaX.76.Redhat7_2 src.rpm from the hp software & drivers, spec. the cmaX module. first, the cmaX.c calls for header files not yet installed (sort of like the chicken and the egg question). the rpm build kept balking at this portion of c source:
/* ucd-snmp */

i got around this by building a temp. ucd-snmp rpm without the cmax module, installing that, then rebuild the rpm with cmax. installed that and tried to start the agent, but it gives me this error in the messages:
localhost ucd-snmp[8144]: cmaX: cmaX.c, SetUpListenSocket (725): bind() failed!

strace shows this:
bind(8, {sin_family=AF_INET, sin_port=htons(725), sin_addr=inet_addr("")}}, 16) = -1 EADDRINUSE (Address already in use)
fstat64(3, {st_mode=S_IFREG|0644, st_size=0, ...}) = 0
mmap2(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) = 0x40019000
write(3, "\n", 1) = 1
write(3, "cmaX: cmaX.c, SetUpListenSocket "..., 54) = 54

what?!??!? am i missing something here? netstat shows port 725 only when i start the snmpd agent, so something else in snmpd is using that port. does anyone know what that is ?
Steven E. Protter
Exalted Contributor

Re: problems with ucd-snmp

While you are testing this stuff, turn off your firewall.

service iptables stop
service ipchains stop

Depending on which one you are using.

Steven E Protter
Owner of ISN Corporation
Sang Yi
Occasional Contributor

Re: problems with ucd-snmp

i don't think it's ipfilter that's getting in the way (esp. since i'm not using any). cmaX seems to want to bind to particular socket that's already being used by something in snmpd. has anyone else have problems using the cmaX release of ucd-snmp from hp? for that matter, is anyone using the ucd-snmp with the health agents from hp?

Re: problems with ucd-snmp

Have same problem with ucd-snmp compilation.
Finaly I found that there are big mess with include paths, so I changed them to point to valid files in ucd-snmp patch and source files, and rebuilded rpm package succesfuly.

But recompilation doesn't solved my problem - there are still empty fields in Insight Manager from agents with servers where is RedHat 8.0 installed.