General
cancel
Showing results for 
Search instead for 
Did you mean: 

program runtime error when oracle8.16 to 9i,

huomzh_1
Occasional Visitor

program runtime error when oracle8.16 to 9i,

Hello:
I have a problem. my team write program using proc on oracle816,but now the database is upgraded to oracle9i.we can compile it ok,but when we run it, warring message is displayed and the program exit ,can u help me??
(gdb) bbxhp 28: gdb --directory=/home/bbxdl/A00DA011/ ~/tools/txfCall
Detected 64-bit executable.
Invoking /opt/langtools/bin/gdb64.
HP gdb 3.1 for PA-RISC 2.0 (wide), HP-UX 11.00.
Copyright 1986 - 2001 Free Software Foundation, Inc.
Hewlett-Packard Wildebeest 3.1 (based on GDB) is covered by the
GNU General Public License. Type "show copying" to see the conditions to
change it and/or distribute copies. Type "show warranty" for warranty/support.
..
(gdb) r -e A00DA011.def -d test.dat -o test1.dat
Starting program: /home/bbxdl/tools/txfCall -e A00DA011.def -d test.dat -o test1
.dat
warning: Version of shared library /oracle/product/9.2.0/lib/libclntsh.sl.9.0 no
t understood; there may be new features in the library that gdb does not support
.
.
.

Program exited normally.

thanks a lot.
4 REPLIES
ranganath ramachandra
Esteemed Contributor

Re: program runtime error when oracle8.16 to 9i,

i guess you are talking about this message:
---
warning: Version of shared library
/oracle/product/9.2.0/lib/libclntsh.sl.9.0 no
t understood; there may be new features in the library that gdb does not support
---
this is a gdb warning and the latest hp gdb (i guess version 3.4) takes care of it.

are you seeing any problem running the program outside of gdb too ? please make sure you have the latest loader patches installed (PHSS_30048 for 11.00, PHSS_30049 for 11.11).
Jean-Luc Oudart
Honored Contributor

Re: program runtime error when oracle8.16 to 9i,

While this problem require investigation, you could use the oracle816 client software against the oracle 9i database.

Another thing, oracle8 default client is 32 bits, oracle9i default client is 64 bits.
Choose the right library !

Regards,
Jean-Luc
fiat lux
huomzh_1
Occasional Visitor

Re: program runtime error when oracle8.16 to 9i,

hello,thanks ur help.
but can u tell me how to select the library?
Jean-Luc Oudart
Honored Contributor

Re: program runtime error when oracle8.16 to 9i,

On oracle8i, there are 2 lib directory :
$ORACLE_HOME/lib (32 bits)
$ORACLE_HOME/lib64 (64 bits)
The SHLIB_PATH must be initialised with the required one.

Regards,
Jean-Luc
fiat lux