Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
General
cancel
Showing results for 
Search instead for 
Did you mean: 

qlogic scsi I/O errors qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.

Srikanth_14
Occasional Advisor

qlogic scsi I/O errors qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.

Hi Folks ,
I am running into an issue where some of the luns on the EVA 8000 ( XCS 6.0) become inaccessable and when i look at the /var/log/messages i see the following.

Dec 22 17:21:15 casl-cgn3 kernel: qla2300 0000:0a:01.0: qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.
Dec 22 17:21:26 casl-cgn3 kernel: SCSI error : <0 0 0 1> return code = 0x50000
Dec 22 17:21:26 casl-cgn3 kernel: end_request: I/O error, dev sda, sector 88

The server is running SLES 9 SP3 2.6.5-7.252 kernel (64 bit. The EVA has no signs of any disk failure and seems to be in a healthy state. We have tried creating different luns on the EVA but the issue seems to pop up unpredictably . Everything seems to be working fine but suddenly we see the scsi command timeout issues showup.
The HP certified Qlogic driver 8.01.03-p5 is currently used.
All ideas are greatly appreciated.

Thanks,
Srikanth
6 REPLIES
Steven E. Protter
Exalted Contributor

Re: qlogic scsi I/O errors qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.

Shalom,

Standard diagnostic procedures apply:
1) Check cables for damage.
2) Physically inspect the cards and see that proper lights are on.
3) Check the switch and see the connection is active.
4) Check and see if the HBA card is still recognized and functioning.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Srikanth_14
Occasional Advisor

Re: qlogic scsi I/O errors qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.

Steven,

This is a clustering file serving product. There are about 10 nodes in a cluster and all of them complain about the scsi errors. We have already checked the cables, links and other basic diagnostics. The backend storage doesnt complain about any issues ( no drive or other hardware problems ). In the beginning everything appears to be fine but after a few hrs later we see the errors in the /var/log/messages. Why could there be a scsi timeout in the backend. The only traffic that is flowing is the clustering information stored on the quorom disks. The above error occurs on one of the quorom disk. The product and the backend is not serving any data so there is no load on the switch or EVA.

Thanks,
Srikanth
George Liu_4
Trusted Contributor

Re: qlogic scsi I/O errors qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.

try to reboot the sever. It could be a kernel/RAID driver bug. If it is a hw problem, you will see the same error on dmesg when it reboots
Ron Nash
Advisor

Re: qlogic scsi I/O errors qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.

Hello Srikanth,

I was wondering if you ever resolved this issue. I am having the same problem and have a similar setup. I took the recommendation of Steven E. Protter and found that a port the Fiber switches is amber. Tried to replace the cable, and module, but this did not change the link light green. Every thing looks setup right from the switch level, but have not been able to resolve this issue. I am also very new to this type of setup.

Thank you,
RN
Patrick Terlisten
Honored Contributor

Re: qlogic scsi I/O errors qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.

Hello,

did you see any errors in the logs of the fc-switches? You can try to deactivate the auto-neogation on the fc-switch port and set it to a fixed speed.

Regards,
Patrick
Best regards,
Patrick
Ron Nash
Advisor

Re: qlogic scsi I/O errors qla2xxx_eh_abort scsi(0:0:0:1): cmd_timeout_in_sec=0x1e.

I think my problem is resolved. I changed the failover path for the Qlogic FC adapter to "Path A-Failover/failback" in the EVA CommandView "Vdisk Active Member Properties.

Thanks,

RN