General
cancel
Showing results for 
Search instead for 
Did you mean: 

redhat 7.2 - problem upgrading from kernel 2.4.7-10

Francisco Mancardi_1
Frequent Advisor

redhat 7.2 - problem upgrading from kernel 2.4.7-10

Hi!:
This is part 2 of my problem that began
with the question about memory problems.

I've downloaded and installed the rpm (see attachment).
Boot OK, but when I try to build VMWARE workstation, the script complain about not
finding the includes.

Then I've tried to find the sources
for 2.4.20-24.7, but was impossible.
I've downloaded 2.4.20 from kernel.org.

The vmware script continues to complain
now because it can't find version.h

I've tried:
1. copy from boot the configfile for the new kernel
2. make dep -> failed: no asm dir
3. I've created a link asm
4. make dep -> failed again
with a message abou no rule to make target autoconf

Any hint ?

best regards



7 REPLIES
Mark Grant
Honored Contributor

Re: redhat 7.2 - problem upgrading from kernel 2.4.7-10

Your problem is probably that vmware needs to find the kernel header files to build the modules it needs.

I don't think you need to install a new kernel or anything like that. Just have the kernel sources somewhere. It is possible that vmware just can't find where your header files are but it does actually ask you where they are. Normall, of course, they would be in /usr/src/linux/include but I imagine Red Hat would put them somewhere else.

Make sure that you have installed the kernel sources though!
Never preceed any demonstration with anything more predictive than "watch this"
Huc_1
Honored Contributor

Re: redhat 7.2 - problem upgrading from kernel 2.4.7-10

On Redhat 2.4.20-27.9 on wich I have the kernel source install I find many version.h but only two valid candidates.

/usr/include/linux/version.h
and in
/usr/src/linux-2.4.20-27.9/include/linux/version.h

I found these with

#locate version.h | grep "/version.h"

in /usr/src/linux-2.4 there is a softlink to current kernel version "in my case 2.4.20-27.9"

I did a diff between the two files and found the following

diff /usr/include/linux/version.h /usr/src/linux-2.4.20-27.9/include/linux/version.h
1c1,10
< #define UTS_RELEASE "2.4.20"
---
> #include
> #if defined(__module__smp)
> #define UTS_RELEASE "2.4.20-27.9smp"
> #elif defined(__module__BOOT)
> #define UTS_RELEASE "2.4.20-27.9BOOT"
> #elif defined(__module__bigmem)
> #define UTS_RELEASE "2.4.20-27.9bigmem"
> #else
> #define UTS_RELEASE "2.4.20-27.9"
> #endif

I haven install VMWARE on this system so can not confirm that my system would be more succesfull, but I am hoping that this could somehow help you out ... in any case it answers Mark question ..

J-P
Smile I will feel the difference
Huc_1
Honored Contributor

Re: redhat 7.2 - problem upgrading from kernel 2.4.7-10

I should also have added the following

# rpm -ql kernel-source-2.4.20-27.9 | grep "version.h"
/usr/src/linux-2.4.20-27.9/arch/i386/math-emu/version.h
/usr/src/linux-2.4.20-27.9/drivers/addon/aep/driver_version.h
/usr/src/linux-2.4.20-27.9/drivers/addon/cipe/version.h
/usr/src/linux-2.4.20-27.9/drivers/addon/iscsi/iscsi-version.h
/usr/src/linux-2.4.20-27.9/drivers/addon/iscsi/version.h
/usr/src/linux-2.4.20-27.9/drivers/addon/qla2200/qla_version.h
/usr/src/linux-2.4.20-27.9/drivers/net/sk98lin/h/skversion.h
/usr/src/linux-2.4.20-27.9/include/linux/version.h
/usr/src/linux-2.4.20-27.9/include/pcmcia/version.h

The above show me the version.h found in the rpm kernel-source that is installed on my system.

J-P (0 point for this added to... and may I added Happy new year to you lot !)


Smile I will feel the difference
Francisco Mancardi_1
Frequent Advisor

Re: redhat 7.2 - problem upgrading from kernel 2.4.7-10

Hi: there are news.
using red hat network I've downloaded
and installed:

kernel-bigmem-2.4.20-27.7.i686.rpm

kernel-BOOT-2.4.20-27.7.i386.rpm
kernel-headers-2.4.9-34.i386.rpm
kernel-source-2.4.20-27.7.i386.rpm
kernel-utils-2.4-8.13.7.2.i386.rpm

I've not found -source-*.i686

reboot OK

now vmware-config.pl failed with this
message:

the kernel defined by this directory
of header files is uniprocessor,
while your running kernel is multiprocessor.

anyone knows what include file i need
to modify ?

best regards
Don_89
Trusted Contributor

Re: redhat 7.2 - problem upgrading from kernel 2.4.7-10

1) Looks like your running the SMP kernel, you can check this by typing -> uname -a. Vmware is trying to compile for a uniprocessor kernel.

2) If your you have a single processor machine, you might have a option at bootup to load the uniprocessor kernel.. If not, you have to modify your /etc/lilo.conf or /etc/grub file depending on your loader.

3) if you have a dual processor machine, you need to specify the correct directory when VMware looks for the C header files. it should be something like /usr/src/2.4.9.20-SMP/include


hopefully this helps..
Steven E. Protter
Exalted Contributor

Re: redhat 7.2 - problem upgrading from kernel 2.4.7-10

You should probably get your kernels from Red HAt's update function. It should not make a difference, but readhats update program handles certain details correctly that you may have missed.

Try it that way and report back.

SEP
Steven E Protter
Owner of ISN Corporation
http://isnamerica.com
http://hpuxconsulting.com
Sponsor: http://hpux.ws
Twitter: http://twitter.com/hpuxlinux
Founder http://newdatacloud.com
Martin P.J. Zinser
Honored Contributor

Re: redhat 7.2 - problem upgrading from kernel 2.4.7-10

Hello,

kernel-source-2.4.20-27.7.i386.rpm


is the source tree you need. The 686 for the build kernel is just a matter of compiler optimisations and maybe a config variable, but not an issue of the source itself.

Most probably your problem is that the source has been unpack to /usr/src/linux-2.4.20xx.
Make /usr/src/linux a link pointing to this and you should be fine.

Greetings, Martin