cancel
Showing results for 
Search instead for 
Did you mean: 

rlogin not working

SOLVED
Go to solution
j.bobby
Frequent Advisor

rlogin not working

hi guys,

i am facing problem with rlogin between my HP 9000 servers.i have checked the entries in .rhosts and /etc/hosts files.they are fine.while i am trying to rlogin from one host to another one, it is giving nothing.please suggest me what are the things i need to to check further.

regards
bobby.
9 REPLIES
VK2COT
Honored Contributor

Re: rlogin not working

Hello,

a) Check /etc/inetd.conf. Is this protocol
enabled on the remote server.

b) Check /var/adm/inetd.sec. Is rlogin
managed via access control list?

c) Check Bastille:

bastile -l

Are you running high level of security?

d) Check log files on the remote server
(/var/adm/syslog/syslog.log).

e) Can you reach remote server through
other protocols or tests (ping, telnet,
ssh)? Maybe your network setup is wrong.

As you can see, many issues to worry about.

Cheers,

VK2COT
VK2COT - Dusan Baljevic
skt_skt
Honored Contributor

Re: rlogin not working

what is the exact error u r getting?
Dennis Handly
Acclaimed Contributor

Re: rlogin not working

What are the permissions of .rhosts?
It should be 600: -rw-------
Sani
Frequent Advisor
Solution

Re: rlogin not working

Hi ,

Please check /etc/inetd.conf and sure that "rlogind" is enabled.

there should be a line as follows

login stream tcp6 nowait root /usr/lbin/rlogind rlogind

make sure there is no remark (#) for the line.

restart "inetd" using "inetd -c "

Regards
Sanil
j.bobby
Frequent Advisor

Re: rlogin not working

Hi guys,

thanks to all of you.Thank u sani.I checked with /etc/inetd.conf and as u suspected "rlogind" is diasbled.there is a "#" for the corresponding line.Now after enabling,should i compulsarily restart it.Will it show any impact on running application.


Thanks & Regards
Bobby




Dennis Handly
Acclaimed Contributor

Re: rlogin not working

>Will it show any impact on running application?

No, it should just start rlogind.
Johnson Punniyalingam
Honored Contributor

Re: rlogin not working

restart "inetd" using "inetd -c "

The above command will not make any impact,

inetd -c " will re-read or refresh the /etc/inetd.conf file" to take effect of the changes to your inetd.conf file,

For more explanation" man inetd"

Thanks,
JOhnson
Problems are common to all, but attitude makes the difference
j.bobby
Frequent Advisor

Re: rlogin not working

OK.

Thanks a lot to all of you for your valuable information and guidance.

Regards
Bobby.
Sani
Frequent Advisor

Re: rlogin not working

Hi Bobby ,

Yes . you need to restart the service.As i mentioned use "inetd -c " to re-read the configuration file (inetd.conf)

Regards
sanil