Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
cancel
Showing results for 
Search instead for 
Did you mean: 

rlogin problem

SOLVED
Go to solution
Bruno Misculin Rosamili
Occasional Advisor

rlogin problem

Hi,

if I try to connect to a system with rlogin I got "rlogind: Unable to allocate pty on remote host", if I try with telnet works fine.
What does it means?

Bye

4 REPLIES
PIYUSH D. PATEL
Honored Contributor
Solution

Re: rlogin problem

Hi,

Check whether the ftp service is enabled on the remote server in /etc/services files and /etc/inetd.conf file.

You are running out of pts drivers on the server. Do this

a) Check the number of pty/s drivers that are created in /dev/pty and /dev/pts :-
# ls *|wc -l
Most likely you'll get 60 (ie the default).

b) Increase the count to say 200
# cd /dev
# insf -n200 -dpty0
# insf -n200 -dpty1
# insf -d pts -s 200 -e

c) Now try to login again.

HPUX 11 introduced the 'nstrtel' parameter which must also be utilised.

# cd /dev
# insf ???d pty ???s 1024 ???e ???v
# insf ???d ptm ???s 1024 ???e ???v
# insf -d telm ???s 1024 ???e ???v
# insf -d tels ???s 1024 ???e -v

Piyush


Helen French
Honored Contributor

Re: rlogin problem

This document may be helpful (TKB #A5399288):

http://support1.itrc.hp.com/service/cki/docDisplay.do?docLocale=en_US&docId=200000027709246

Life is a promise, fulfill it!
S.K. Chan
Honored Contributor

Re: rlogin problem

You ran out of of pts driver. Do this to verify and if needed increase the pty/s drivers.
a) In SAM->KernelConfig->Drivers
Make sure "ptm", "pts" and "ptem" are in the kernel. If not add them and rebuilt/reboot your machine.
b) After a) is done ..check the number of pty/s drivers ..

# cd /dev/pty
# ls *|wc -l
# cd /dev/pts
# ls *|wc -l

The default should be 60 and if that's the case increase them .. (say to 200)

# cd /dev
# insf -n200 -dpty0
# insf -n200 -dpty1
# insf -d pts -s 200 -e
MANOJ SRIVASTAVA
Honored Contributor

Re: rlogin problem

Hi Bruno


It looks like the npty is maxed out

check for the setting like like


ls /dev/pty | wc -l

and to increase it :

cd /dev
insf -n300 -dpty0
insf -n300 -dpty1
insf -d pts -s 300 -e

this will increse it to 3000 from the default ,


Manoj Srivastava