cancel
Showing results for 
Search instead for 
Did you mean: 

rsync problem

emily_3
Frequent Advisor

rsync problem

This is my first time to use rsync,
I tried to transfer files between two linux server, but it failed at the following:
################################
#rsync host1:/tmp/a /tmp/
host1: Connection refused
unexpected EOF in read_timeout
#################################
Any other configuration I need to do, besides /etc/rsyncd.conf file? Thanks.

9 REPLIES
U.SivaKumar_2
Honored Contributor

Re: rsync problem

Hi,

Use --timeout option with rsync command and specify 900 as value

--timeout 900

regards,

U.SivaKumar.
Innovations are made when conventions are broken
emily_3
Frequent Advisor

Re: rsync problem

i tried #rsync -C --timeout=900 file1 file2
but still the same error.

Any security need to set up? Thanks.
Robert Binkhorst
Trusted Contributor

Re: rsync problem

Hi,

What version of rsync/OS are you using?

In the mean time, this document might help:
http://sunsite.dk/info/guides/rsync/rsync-mirroring02.html

HTH,

Robert
linux: the choice of a GNU generation
emily_3
Frequent Advisor

Re: rsync problem

if i am not wrong, it's Version 1.
Robert Binkhorst
Trusted Contributor

Re: rsync problem

And which OS? RedHat AS2.1/SuSe?
linux: the choice of a GNU generation
emily_3
Frequent Advisor

Re: rsync problem

GNU/Linux 2.4.0
Paul Cross_1
Respected Contributor

Re: rsync problem

rsync requires .rhost entries on the remote machine... can you rsh to the rsync recipient without a password?
Vitaly Karasik_1
Honored Contributor

Re: rsync problem

Is rsync/rsh enabled?

["chkconfig rsync on" in RedHat/Mandrake].

Do you have correct .rhosts file?

for root user you should add "rsh" into /etc/securetty file

rgds,
Vitaly

Re: rsync problem

One should really only run rsync using ssh.

Have ssh passwordless logins and scp
working between the machines.

In bash_profile on both have
"export RSYNC_RSH=ssh"

Then your command should work. Use -v for
help if it doesn't.

For syncing directories, the -a option is nice.

Mike