cancel
Showing results for 
Search instead for 
Did you mean: 

rx2600 and emulex lp7000

Cristian Ali
Occasional Contributor

rx2600 and emulex lp7000

I can??t see an emulex board lp7000 on a HP Server rx2600, in the EFI interface, I have the efiutil.efi, when I run efiutil at the first screen we see:

Emulex Fibre Channle Host Adapter Detected: 1
Host Adapter 0(lpfc0) is an Unknown Device (FFE20000 00000000) (Unknown Mode)

What??s wrong ?

We can??t see and open the LP700??s BIOS at boot time. Is it normal in Itanium architecture? We tested the lp7000 in a Proliant 1600 and it works perfectly.

* The HP Server is a RX2600 with one processor.
* The version kernel is Red Hat Linux Advanced Server for the Itanium 2 processor (IA-64) with 2.4.18-e.25 kernel.
* The BIOS in the LP7000 is Firmware version 3.30a7 for LP7000/E Universal Boot version 3.11a0

Regards,

Cristian
1 REPLY
I_M
Honored Contributor

Re: rx2600 and emulex lp7000

Hi,

If you want to manipulate SCSI BIOS on IA64 system, I know how to do. But I am not sure this procedure still works on your FC card. Just try.

(1) From EFI shell, use debtree.

Shell???devtree -b
Device Tree
.
.
.
Ctrl[0D] Acpi(HWP0002,400)
Ctrl[15] LSI Logic Ultra 160 SCSI Controller

Record the [15] on paper.

(2) From EFI shell, use drvcfg

Shell??? drvcfg
Configureable Components
Drv[33] Ctrl[15] Lang[eng] <===
Drv[33] Ctrl[16] Lang[eng]
Drv[34] Ctrl[1A] Lang[eng]

Find [15]

(3) From EFI shell, use drvcfg again
Shell???drvcfg -s 33 15

Now you get SCSI BIOS screen.

I think you may follow this procedure to start your FC BIOS setting screen.

======
I have configured an Emulex lp8000 on RedHat(IA32) before.
I had to download the driver from emulex.com, then compile the driver. It worked fine.

On your OS (I guess it is RHAS 2.1(IPF)), can you find the card using # lspci -v ? or cat /proc/pci?

Regards,