Simpler Navigation for Servers and Operating Systems - Please Update Your Bookmarks
Completed: a much simpler Servers and Operating Systems section of the Community. We combined many of the older boards, so you won't have to click through so many levels to get at the information you need. Check the consolidated boards here as many sub-forums are now single boards.
If you have bookmarked forums or discussion boards in Servers and Operating Systems, we suggest you check and update them as needed.
Showing results for 
Search instead for 
Did you mean: 

service guard errors when starting cluster

Helen Macdonald
Occasional Contributor

service guard errors when starting cluster

Service Guard
I have created a cluster file
volume groups currently activated
Done a cmapplyconf -C cmclconf.ascii
cmruncl -v
Failed to start cluster which is what I expected as volume groups are not cluster aware yet.
deactivated volume groups then tried to make volume groups cluster aware.
Following error displayed
"cmtaped kernel tuneable st_ats_enabled disabled for ATS.

I tried setting st_ats_enabled to 1 and now the following error is displayed

"cmtaped there is no ATS device on this cluster"

Set kernel parameter back to 0

Tried to start cluster again same error as before.

The cmcld daemon will not start thus I am unable to make my volume groups cluster aware.

Any Ideas

Dietmar Konermann
Honored Contributor

Re: service guard errors when starting cluster

Hi, Helen!

From my experience both of your cmtaped messages are only warnings. The cluster should still form.

So I assume your problem is something complete different. Any other messages? What SG revision?

During the (susequently failing) formation... are there already cmcld processes runnning on all nodes?

"Logic is the beginning of wisdom; not the end." -- Spock (Star Trek VI: The Undiscovered Country)
Honored Contributor

Re: service guard errors when starting cluster

Hi Helen,

Try the SG Cookbook from ITRC,

And the SG docs from hp docs.

Try the doc "Managing SG"

Hope this helps.

Jeff Schussele
Honored Contributor

Re: service guard errors when starting cluster

Hi Helen,

Not knowing what OS or MC/SG versions you're running, I would suggest that you look at the following 11.0 patches


or it superseding patch

These will update MC/SG to 11.13 & will default st_ats_enabled to NOT enabled & not force the check for ATS devices.

The problem w/11.0 & 11i & ATS is they default to st_ats_enable & enforce the ATS device check.

If not 11.0 you'll have to look for corresponding patches.

Anyway - it's worth a look.

PERSEVERANCE -- Remember, whatever does not kill you only makes you stronger!
Helen Macdonald
Occasional Contributor

Re: service guard errors when starting cluster

Many thanks.

I have now resolved the problem. There was a problem with connecting to the other node.