General
cancel
Showing results for 
Search instead for 
Did you mean: 

setting up epson stlyus color 900 on freebsd 7

itrcfan
Occasional Contributor

setting up epson stlyus color 900 on freebsd 7

hi everybody,
okay i know this is a Linux subforum but maybe it is not too offtopic because if someone know how to get this working on linux, i'm sure it's going to work on freebsd too.
first i've tried to get some help in a german bsd related forum, but noone would reply.
today i've created a thread in the usenet, but noone would reply.
so i try my luck here. thank you for your understanding in advance.

this it the url to the original posting:
http://groups.google.com/group/comp.unix.admin/browse_thread/thread/6a9c0032af714aaf#

i'll copy the text here (it's my personal text):

----------------------------
hi everybody,
first of all i hope i'm posting in the correct group.
three days ago i decided to hook up my epson stylus color 900 printer on my freebsd machine.
so i've connected it to the printer port using classic centronics cable and followed the steps until Advanced Printer Setup from the official freebsd documentation
(handbook, section printig).
we are talking about a parallel printer now and the Simple Printer Setup works excellent.

$ echo "Hello EPSON Stylus Color 900! :-)" | lpr

works ^^ but the output quality is not nice. the document gets printed with with low resolution and 360dpi, i think

now i only need a better printing resolution (higher resolution: high or photo, 720 dpi)

do i necessarily need cups for this? ^^
i don't think so, because the spooling works perfect.

i think apsfilter can handle this, but my printer seems not to be supported?

# cd /usr/local/share/apsfilter
# ./SETUP
Found ghostscript version 8.63 ...
You have to upgrade at least to gs version 6.50!
But you should upgrade to gs 7.00 for full driver support
prior installing printers with SETUP.
Do you you want to continue? [Y/n] Y

.
.
.

s to continue

1 - Epson AcuLaser C2000 [alc2000]
2 - Epson AcuLaser C8500 [alc8500]
3 - Epson Laser EPL-N2050 [epl2050]
4 - Epson Laser EPL-N2050+ [epl2050p]
5 - Epson Laser EPL-N5800 [epl5800]
6 - Epson Stylus Color 20 series {png+pips} [pips/sc20s]
7 - Epson Stylus Color 40 series {png+pips} [pips/sc40s]
8 - Epson Stylus Color 60 series {png+pips} [pips/sc60s]
9 - Epson Stylus Color 70 series {png+pips} [pips/sc70s]
10 - Epson Stylus Color 80 series {png+pips} [pips/sc80s]
11 - Epson Stylus Color 480 {png+pips} [pips/sc480]
12 - Epson Stylus Color 580 {png+pips} [pips/sc580]
13 - Epson Stylus Color 680 {png+pips} [pips/sc680_777]
14 - Epson Stylus Color 777 {png+pips} [pips/sc680_777]
15 - Epson Stylus Color 880 {png+pips} [pips/sc880]
16 - Epson Stylus Color 980 {png+pips} [pips/sc980]
17 - Epson Stylus Photo 810 {png+pips} [pips/sp810_820]
18 - Epson Stylus Photo 820 {png+pips} [pips/sp810_820]
Which driver do you want to choose?
[Hit RETURN to see the list again, enter 0 to choose new type.]

Enter number:
.
.
.
==================================================================
A P S F I L T E R S E T U P -- MAIN MENUE --
==================================================================

(D) Available Device Drivers in your gs binary
(R) Read Ghostscript driver documentation (devices.txt)

(1) Printer Driver Selection []
(2) Interface Setup [parallel]
(3) Paper Format [a4]
(4) Printing Quality [photo]
(5) Color Mode [gray]
(6) Print Resolution in "dots per inch" [720x720]
(7) Default Printing Method [auto]

(A) Abort installation (don't do anything)
(Q) ==> Finish installation

Your choice?

# lpr -P lp -C high testprint

this configuration won't work and the "-C high" parameter shows no effect.

$ cat /etc/printcap
# This file was automatically generated by cupsd(8) from the
# /usr/local/etc/cups/printers.conf file. All changes to this file
# will be lost.
lp|line|myprinter|my epson:\
:sh:sd=/var/spool/epson:\
:lp=/dev/lpt0:\
$

is there any other way to get this problem solved?

hope i will find some qualified help/inspiration here.

kind regards

----------------------------