General
cancel
Showing results for 
Search instead for 
Did you mean: 

spool file owner 'oracle' instead of OS athenticated user

spool file owner 'oracle' instead of OS athenticated user

I'm experimenting a strange behaviour when connecting to an Oracle 10g database (10.2.0.3) with an externally identified user (namely 'backora'): the owner of the spool file is 'oracle' instead of 'backora'. Example:

myhostname: /home/backora $ sqlplus /
SQL> spool lixo
SQL> select sysdate from dual;

SYSDATE
--------
07.11.02

SQL> spool off
SQL> !ls -ltr
-rw-r--r-- 1 oracle oinstall 291 Nov 2 19:49 lixo.lst

Is this an instalation problem? I had to apply 'changePerms.sh', so other users other than 'oracle' can connect. umask 022 in 'oracle' an 007 in 'backora'.

How can i turn around this issue?
3 REPLIES
Yogeeraj_1
Honored Contributor

Re: spool file owner 'oracle' instead of OS athenticated user

hi Alberto,

Can you verify the following?

1. The id of oracle and backora:

$ id oracle
$ id backora

2. Spool path
Try to spool to another path and see what happens.

e.g.
SQL> spool /tmp/lixo

3. Remove the file lixo.lst and retry the spool operation.

revert!

kind regards
yogeeraj
No person was ever honoured for what he received. Honour has been the reward for what he gave (clavin coolidge)

Re: spool file owner 'oracle' instead of OS athenticated user

Some hints to clarify:

OS: HP-UX 11.11
BD: Oracle 10g Database w/ patchset2 (10.2.0.3)

myhostname: / # id oracle
uid=107(oracle) gid=104(oinstall) groups=105(dba)

myhostname: / # id backora
uid=108(backora) gid=105(dba)

This user 'backora' is identified externally and it's only function is to run backup jobs. By some strange reason, in this machine, the spool file is produced with 'oracle' ownership instead of 'backora'. Despite they belong to the same 'dba' group, in some parts of the backup scripts it must do 'chmod' and fails because it's not the owner of the spooled file.

Re: spool file owner 'oracle' instead of OS athenticated user

Thank you for your sugestion: i've tried but with no success:

$ sqlplus /

SQL> spool /tmp/test
SQL> select * from v$version;

BANNER
-------------------------------------------
Oracle Database 10g Enterprise Edition Release 10.2.0.3.0 - 64bi
PL/SQL Release 10.2.0.3.0 - Production
CORE 10.2.0.3.0 Production
TNS for HPUX: Version 10.2.0.3.0 - Production
NLSRTL Version 10.2.0.3.0 - Production

SQL> spool off
SQL> !ls -ltr /tmp
-rw-rw---- 1 oracle oinstall 614 Nov 3 10:31 test.lst

= = =
This problem arise with the migration from 9i to 10g: after 10g install i had to apply 'changePerms.sh', so other users other than 'oracle' can connect - 4516865:WRONG PERMISSIONS AFTER INSTALLATION IN OH AND SUBSEQUENT DIRECTORIES

AR