cancel
Showing results for 
Search instead for 
Did you mean: 

ssh problem

gigiz
Valued Contributor

ssh problem

I am trying to do a ssh on the my server.
ssh
this gives me an error:
ssh
/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'krb5_ser_context_init' in load module '/usr/lib/hpux32/libgssapi_krb5.so'.
/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'krb5_ser_auth_context_init' in load module '/usr/lib/hpux32/libgssapi_krb5.so'.
/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'krb5_ser_ccache_init' in load module '/usr/lib/hpux32/libgssapi_krb5.so'.
/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'krb5_ser_rcache_init' in load module '/usr/lib/hpux32/libgssapi_krb5.so'.
/usr/lib/hpux32/dld.so: Unsatisfied code symbol 'krb5_ser_keytab_init' in load module '/usr/lib/hpux32/libgssapi_krb5.so'.
Killed

ldd -r -s `which ssh`

symbol not found: krb5_auth_con_setuseruserkey (/usr/lib/hpux32/libgssapi_krb5.so)
symbol not found: krb5_set_default_tgs_enctypes (/usr/lib/hpux32/libgssapi_krb5.so)
symbol not found: krb5_auth_con_getremoteseqnumber (/usr/lib/hpux32/libgssapi_krb5.so)
symbol not found: krb5_internalize_opaque (/usr/lib/hpux32/libgssapi_krb5.so)
symbol not found: krb5_free_ap_req (/usr/lib/hpux32/libgssapi_krb5.so)
symbol not found: decode_krb5_ap_req (/usr/lib/hpux32/libgssapi_krb5.so)
symbol not found: krb5int_cc_default (/usr/lib/hpux32/libgssapi_krb5.so)
symbol not found: krb5_ser_context_init (/usr/lib/hpux32/libgssapi_krb5.so)
symbol not found: krb5_ser_pack_int32 (/usr/lib/hpux32/libgssapi_krb5.so
This after installation of 10 product downloaded from porting e archiving center.
Any help will be great,
Thanks,
4 REPLIES
Calandrello
Trusted Contributor

Re: ssh problem

which are using ssh openssh in interterritorial downloaded and compiled for your self?
or compiled and distributed by HP site www.software.hp.com?
RajuD
Frequent Advisor

Re: ssh problem

Do ssh -v 0 and give local host password and check.
“Education is our passport to the future, for tomorrow belongs to those who prepare for it today.”
Rita C Workman
Honored Contributor

Re: ssh problem

What version of SSH do you have installed?

I remember upgrading our SSH from 4.20 to ver 5.1 (I believe) and hit an error with that very same library for our chroot
environment.

Rgrds,
Rita

yangk
Frequent Advisor

Re: ssh problem

It seems that the series functions is not defined in dynamic library libgssapi_krb5. So maybe you need to update a kerberos client.
Just try!