cancel
Showing results for 
Search instead for 
Did you mean: 

strange characters!!

SOLVED
Go to solution
Lorenzo Facello
Valued Contributor

strange characters!!

When I open pages of man I notice that some character are wrong.
For example in this case all the "-" are "??".
Regards.
6 REPLIES
Balaji N
Honored Contributor

Re: strange characters!!

most probably problem with terminal settings.

check your TERM settings.
-balaji
Its Always Important To Know, What People Think Of You. Then, Of Course, You Surprise Them By Giving More.
John Dvorchak
Honored Contributor

Re: strange characters!!

What is result of:
echo $TERM

Should be the same as the terminal emulator that you are using on the client.

If it has wheels or a skirt, you can't afford it.
Stuart Browne
Honored Contributor

Re: strange characters!!

I figured out what this was recently (ok, so I found the answer on Google!), and it has nothing to do with the temrinal 'type'.

It has to do with the emulation software you are using not supporting Unicode characters.

To fix this, you've got two choices:

1) change emulation software to something that does support Unicode (International) character sets.

2) change the LANG environment to something simpler when using man, like this:

env LANG=C man

Hope this helps you out.
One long-haired git at your service...
T G Manikandan
Honored Contributor
Solution

Re: strange characters!!

If you are using English.Then try setting

LANG=en_US
export LANG


Revert
Tibor Bajnok
Occasional Advisor

Re: strange characters!!

It was the same situation with RH 8.
The default charset was UTF-8.
I realized not sufficient just TERM=en_US
but TERM=en_US.ISO-8859-2 (according to
user's country).
You can see these settings by 'locale' command.
Tibor Bajnok
Occasional Advisor

Re: strange characters!!

Sorry,
not TERM=en_US.ISO-8859-2 but
naturally LANG=en_US.ISO-8859-2

I apologize writing that.