General
cancel
Showing results for 
Search instead for 
Did you mean: 

swinstall - swlist fails with errors

moonchild
Regular Advisor

swinstall - swlist fails with errors

Hi,

It started while installing patches and got the following errors:

ERROR: Ambiguous version tag encountered. Please contact the depot packager for a depot with all version attributes filled in.
If all version attributes are already filled in, check your installed products for ambiguous version tags.

SO I ran swverify to look for any corruption and got the following":

ERROR: There is currently no installed software on host "moonchild" at location "/".
* Target connection failed for "moonchild:/".

tried recreating the index following the itrc doc but still getting the same errors:

# swlist -l file void
# Initializing...
# Contacting target "moonchild"...
ERROR: The expected depot or root does not exist at "/".
ERROR: There is currently no installed software on host "moonchild" at location "/".

# swinstall -x ask=true -s /var/spool/sw/void.depot \*

======= 09/03/09 11:45:14 PDT BEGIN swinstall SESSION
(non-interactive) (jobid=moonchild-0358)

* Session started for user "root@moonchild".

* Beginning Selection
* "moonchild:/": This target does not exist and will be created.
ERROR: There is currently no depot software on host "moonchild" at location "/var/spool/sw/void.depot". Make sure that an absolute pathname is specified for location (beginning with "/").

nslookup resolves successfully both ways.

Thank you in advance
8 REPLIES
James R. Ferguson
Acclaimed Contributor

Re: swinstall - swlist fails with errors

Hi:

Verify that you can resolve your hostname to an address and vice versa.

Try restarting the 'swagentd' daemon:

# swagentd -r

Verify that you have an Installed Product Database (IPD):

# ls -lR /var/adm/sw

If the IPD has been removed, either restore it from backup or plan not to use any SD tools until you re-install.

Regards!

...JRF...
moonchild
Regular Advisor

Re: swinstall - swlist fails with errors

nslookup resolves both ways.
Will try the other recommendations and get back to you.

thanks
moonchild
Regular Advisor

Re: swinstall - swlist fails with errors

The IPD is there.

restarted the swagentd but still getting the same error.
Fabio Ettore
Honored Contributor

Re: swinstall - swlist fails with errors

Hi,

I read you've followed a procedure from an itrc doc to rebuild INDEX, where is this document? Please provide link.

Best regards,
Fabio
WISH? IMPROVEMENT!
Mel Burslan
Honored Contributor

Re: swinstall - swlist fails with errors

> IPD Is there...

Then it must be corrupted. Otherwise swlist should be able to list the software installed on this server and come up with the basics at the least, even this was a fresh install.

You can try rebuilding it. Please see the step-by-step procedure in this thread:

http://forums13.itrc.hp.com/service/forums/questionanswer.do?admit=109447627+1252082224105+28353475&threadId=1174176

HTH
________________________________
UNIX because I majored in cryptology...
IT Response
Esteemed Contributor

Re: swinstall - swlist fails with errors

I followed the step by step creation of the INDEX file but it fails when i run the swinstall with :

ERROR: There is currently no installed software on host "moonchild" at location "/".
* Target connection failed for "moonchild:/".

it only works when i move the INDEX file back into place.
moonchild
Regular Advisor

Re: swinstall - swlist fails with errors

Whenever I move the INDEX file and run the swinstall void I get the following error:

ERROR: There is currently no depot software on host.

but if I keep the INDEX file in place it works fine. I then installed an SD-UX cumulative patch under 11.11 and worked fine.

but when i try to install the OV patch PHSS_38511 it fails with:

ERROR: Ambiguous version tag encountered. Please contact the depot packager for a depot with all version attributes filled in.
If all version attributes are already filled in, check your installed products for ambiguous version tags.

James R. Ferguson
Acclaimed Contributor

Re: swinstall - swlist fails with errors

Hi (again):

> but if I keep the INDEX file in place it works fine. I then installed an SD-UX cumulative patch under 11.11 and worked fine.
but when i try to install the OV patch PHSS_38511 it fails with:
ERROR: Ambiguous version tag encountered.

So if I understand correctly, it is just with _this_ patch that you have a problem.

Have you tried using the superseding patch?

PHSS_39501

Regards!

...JRF...