General
cancel
Showing results for 
Search instead for 
Did you mean: 

terminal time out setings in Linux

SOLVED
Go to solution
skt_skt
Honored Contributor

terminal time out setings in Linux


[root@exgld179p root]# uname -a
Linux hostname 2.4.21-40.ELsmp #1 SMP Thu Feb 2 22:22:39 EST 2006 i686 i686 i386 GNU/Linux
[root@exgld179p root]# cat /etc/redhat-release
Red Hat Enterprise Linux AS release 3 (Taroon Update 7)

I access (using putty and ssh protocol) these servers thorugh WAN connection and after keeping idle for a period of time the session gets hang and i have to open another terminal to work with..

Any one know if any seteeing which could prevent that.
2 REPLIES
Ivan Krastev
Honored Contributor

Re: terminal time out setings in Linux

Change KeepAlive and ClientInterval ssh settings - http://ubuntu.wordpress.com/2006/02/03/keeping-ssh-sessions-alive/


regards,
ivan
Matti_Kurkela
Honored Contributor
Solution

Re: terminal time out setings in Linux

If the session hangs with no message, it suggests there might be a firewall/NAT device between the server and your putty client that stops TCP connections if they have been idle for a long time.

In the PuTTY configuration dialog, see the "Connection" page. There are two options that might help: "Enable TCP keepalives" and "Sending of null packets to keep session active". The TCP keepalives are nicer to the network, but they are not sent very often. If the firewall device has a short timeout, you might use the "sending of null packets" feature instead.

MK
MK