the dc7700 just don't do linux

 
kiwi_3
Occasional Contributor

the dc7700 just don't do linux

If you are looking to buy those nice dc7700 desktops be advised that they don't boot any of the well known linux distros.

They don't run Redhat RHEL4, RHEL5beta2, Fedora Core 6, Fedora Core 5, Fedora Core 4, Ubuntu 6.10, ...

All the reported suggestions like
acpi=off pci=nommconf all-generic-ide jusjavascript:postMessageSubmit('submit');t don't work.

HP Official phone support does not want to open a case as linux is not a supported platform.

53 REPLIES 53
Alpha977
Valued Contributor

Re: the dc7700 just don't do linux

Hello kiwi!

This message is the same i have with an old Ibm GL300.
The problem was the ram.
Can you try to launch Knoppix - Live?
Knoppix 4.0.2 was the only distro start on my machine. Then i changed the ram.

Try to start knoppinx and see.

Regards
Maarten Verwijs
Advisor

Re: the dc7700 just don't do linux

I know the pain.

Fortunatly, I've solved the problem with Debian GNU/Linux and some heavy alternate installing.

The whole problem boils down to the linux kernel not having support for all the neat Intel/HP hardware.

Linux kernel 2.6.19 (released a few days ago) *does* support all the hardware (minus ACPI).

You can get the kernel config I use for building the kernel here:
http://www.sron.nl/~mverwijs/files/2.6.19-rc6-desktops

The way to install Linux on this DC7700 is a pain, but so was the DC7600 when it was first released.

Back then, I wrote a dirty script that I ran from Knoppix. Basically, it did:

Knoppix Method (< DC7700):
==========================
1. boot knoppix
2. format disks
3. use debootstrap to install Debian on the harddrive
4. put my own kernel on the harddrive
5. install grub, pointing to the new kernel on the harddrive
6. reboot
7. profit!

* The Knoppix method will work on DC7700 when Knopper releases a knoppix cd with 2.6.19 kernels.

But, with the dc7700, I can't get Knoppix to boot. So, I now use PXE!

PXE Method:
===========
1. Boot over pxe+tftp using my 2.6.19 kernel
2. Mount / via nfs on a nfs server
3. format the disk on the client
4. install Debian using debootstrap
5. install 2.6.19 on harddisk
6. install grub
7. ....
8. Profit!

PXE is very scalable. And next time there's a new batch of DC9999's coming, I'll just replace the 2.6.19 kernel with the 2.6.51 kernel that'll be out by then.

Alternative method:
==================
1. get disk out of dc7700
2. place disk in older model
3. install debian
4. boot into debian on older model
5. apt-get install kernel-package
6. get kernel source from kernel.org
7. build 2.6.19 kernel with my config
8. place kernel in /boot, update-grub, reboot
9. check everything is in working order
10. remove disk from older model and place in dc7700
11. ...
12. Profit!

Ah... the Joy of Debian!

Pau Garcia i Quiles
Frequent Advisor

Re: the dc7700 just don't do linux

What about this method?

1. Take the hard disk out of the DC7700 and place it in another PC, one which boots Linux fine

2. Install Linux

3. Build your own Linux kernel, if needed (I do not fully understand if the problem is only with Linux not booting for the installation, or not booting at all once installed too)

4. Take the hard disk and place it again in the DC7700

While Windows needs to install in the exact machine you are going to use it, Linux does not take into consideration most of the differences in the systems thanks to the initrd system. The only detail you need to pay attention to is the kernel: make sure you install an i486/i586 kernel if your machine does not support amd64 instructions.
Maarten Verwijs
Advisor

Re: the dc7700 just don't do linux

The only problem I have with taking the harddisk out is that is does not scale.

I have to install Linux on about 20 new machines per year. And I'm lazy. ;-)
T Swan
New Member

Re: the dc7700 just don't do linux

If you can live without ACPI, just disable it. At the boot loader for Fedora/RedHat add acpi=off to loader line.

For example

#linux acpi=off

or

#text acpi=off

This disables ACPI support in the kernel. When RedHat or Fedora installs, it will keep the same the option on the grub.conf loader line.
Issam Mehssani
New Member

Re: the dc7700 just don't do linux

After trying various distros I finally got Debian to install using the latest netinstall cd.

My problem now is that whatever I try, I can't get sound. It looks like it's working, with modules loaded, and songs playing in various software, but no sound coming from the speakers. It works ok in windows, so it's not a hardware problem.
Any tips?
Cedric Dupont
Regular Advisor

Re: the dc7700 just don't do linux

a simple Red Hat 7.3 is able to boot and install on DC7700, no sound, usb, lan and only vesa video after the installation, but it is capable so a new distrib must be ok.

Cédric
afz
New Member

Re: the dc7700 just don't do linux

Hello,

For my answer, I used a DC7700p, RN125ET (cpu E6600, chipset 965Q Express, net 82566 DM)

I was able to boot with kernel parameter :
*
pci=conf1
*

For some distributions, I need to retreive the network driver for the intel pro/1000.
Have a look at the howto :
http://www.intel.com/support/network/sb/cs-009209.htm
and you can find the driver at :
http://sourceforge.net/projects/e1000


[
I also needed sometimes to update the PCI ID's (file pci.ids) from
http://pciids.sourceforge.net/
and then 'lspci' displays full device names instead of the numeric ID's
]

I Hope it will help you.
roko
New Member

Re: the dc7700 just don't do linux

Hello,

I just installed CentOS 4.4 x86_64 (kernel 2.6.9) on a DC7700p (RN123T). The onboard NIC however does not work with this kernel, you 'll need to compile a new one as mentioned by 'afz'.

I also changed a setting in the BIOS:

Storage > Storage Options > SATA Emulation = RAID

This setting will enable the harddrive DMA mode (/dev/sda). Check this with 'hdparm"

# hdparm -t /dev/sda

/dev/sda:
Timing buffered disk reads: 180 MB in 3.02 seconds = 59.59 MB/sec

Regards.